Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MONTANA OWNERS CLUB COMMUNITY > New Member Introductions
Click Here to Login

Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-20-2017, 07:10 AM   #1
peggy loos
New Member
 
Join Date: Jun 2017
Location: fort collins
Posts: 6
M.O.C. #20037
Smile Colorado Montana Owners!!!

Hello Fellow Colorado Montana Owners,
Would love to connect with you...Just purchased our 2015 high country so we are new to this..maby you could share your knowledge.. pls get in touch...
 
peggy loos is offline   Reply With Quote
Old 06-20-2017, 07:25 AM   #2
DQDick
Site Team
 
DQDick's Avatar
 
Join Date: Jun 2011
Location: Wilsey
Posts: 18,799
M.O.C. #11455
Welcome to the forum! Not from Colorado so can't help you there. May your new rig bring you many years of wonderful memories.
DQDick is offline   Reply With Quote
Old 06-20-2017, 07:31 AM   #3
joyce.stevens
Established Member
 
Join Date: Jun 2017
Location: DENTON
Posts: 13
M.O.C. #20045
2015 Montana 3720RL

Purchased my 5th wheel about 3 mos ago and battery needed to be replaced. When I went out last weekend the new battery was showed low voltage on my leveling display. I leave the camper plugged into electric even at my house. Any ideas why that battery went bad other then just a bad battery?
joyce.stevens is offline   Reply With Quote
Old 06-20-2017, 10:57 AM   #4
BB_TX
Montana Master
 
Join Date: Oct 2006
Location: McKinney
Posts: 7,202
M.O.C. #6433
Welcome to the forum. Texas here, but Colorado is one of our favorite place to travel to.

Any question you have about your new rig can almost surely be answered here.
__________________
Bill & Patricia
Riley, our Golden
2007 3075RL (recently sold, currently without)
BB_TX is offline   Reply With Quote
Old 06-20-2017, 11:02 AM   #5
BB_TX
Montana Master
 
Join Date: Oct 2006
Location: McKinney
Posts: 7,202
M.O.C. #6433
Quote:
Originally Posted by joyce.stevens View Post
Purchased my 5th wheel about 3 mos ago and battery needed to be replaced. When I went out last weekend the new battery was showed low voltage on my leveling display. I leave the camper plugged into electric even at my house. Any ideas why that battery went bad other then just a bad battery?
Joyce, I suggest you start a new discussion under the "Montana problems, Problem solving, Technical help" sub forum. You will most likely get more reads and more responses by doing so. It is typically best to start a new discussion rather than tag onto an existing one unless your post relates directly to that existing discussion.

And by the way, welcome to the forum. No better place for all things Montana.
__________________
Bill & Patricia
Riley, our Golden
2007 3075RL (recently sold, currently without)
BB_TX is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 05:59 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.