Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > GENERAL DISCUSSIONS > Tow Vehicles & Towing
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 11-14-2004, 03:56 PM   #1
jh1802
Established Member
 
Join Date: Oct 2004
Location:
Posts: 46
M.O.C. #2162
Prodigy Hookup

I just got a new prodogy brake controller off ebay. Hooked it up to my truck and Nothing happens. The instructions say I should be getting a nc for no connection. I don't get anything. Do you think it is defective? The connectiona are the same as my Envoy, and I just used it 2 days ago so I Know I should be getting power and I double checked my connections. Any Ideas?
jh1802 is offline   Reply With Quote
Old 11-14-2004, 05:16 PM   #2
sreigle
Montana Master
 
Join Date: Nov 2002
Location: Oceanside
Posts: 20,028
M.O.C. #20
Might you have blown a fuse when making the connections? Check the fuse panel?
sreigle is offline   Reply With Quote
Old 11-15-2004, 02:57 AM   #3
315RLS
Montana Master
 
Join Date: Jul 2004
Location: North Andover
Posts: 669
M.O.C. #1900
Quote:
quote:Originally posted by jh1802

I just got a new prodogy brake controller off ebay. Hooked it up to my truck and Nothing happens. The instructions say I should be getting a nc for no connection. I don't get anything. Do you think it is defective? The connectiona are the same as my Envoy, and I just used it 2 days ago so I Know I should be getting power and I double checked my connections. Any Ideas?
Yes you should get the "NC" when initially powered on without your trailer connected, then it will eventually blank after a few minutes.
315RLS is offline   Reply With Quote
Old 11-15-2004, 03:43 AM   #4
jh1802
Established Member
 
Join Date: Oct 2004
Location:
Posts: 46
M.O.C. #2162
Thanks for the input. I'll check the fuses. If not I guess I'll try to send it back.
jh1802 is offline   Reply With Quote
Old 11-15-2004, 04:49 AM   #5
sreigle
Montana Master
 
Join Date: Nov 2002
Location: Oceanside
Posts: 20,028
M.O.C. #20
Also, when hooked up, if you pull the manual slide control all the way over it should also show the nc. There's also two small red dots that light up. I think they come on for a few minutes when you fire up the truck with no trailer attached but my memory may be faulty on that. My Prodigy went with the truck we traded so I can't go check it out for you.
sreigle is offline   Reply With Quote
Old 11-16-2004, 05:40 AM   #6
jh1802
Established Member
 
Join Date: Oct 2004
Location:
Posts: 46
M.O.C. #2162
Checked the fuse last night after work. That was it! Don't know how I blew the fuse but it works fine now. Thanks
jh1802 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
30 amp hookup therollingstones General Discussions about our Montanas 11 11-14-2011 05:42 PM
Prodigy ? campbud Montana Problems, Problem Solving & Technical Help 9 09-12-2005 08:24 AM
Prodigy RMccord General Discussions about our Montanas 14 07-18-2005 08:14 AM
Prodigy help now please stiles watson Tow Vehicles & Towing 14 03-28-2005 10:49 AM
Prodigy Jim Rose Paschal Tow Vehicles & Towing 3 11-13-2004 04:37 PM

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 08:19 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×