Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > GENERAL DISCUSSIONS > General Discussions about our Montanas
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 09-20-2014, 05:55 AM   #21
akf15e
Montana Fan
 
Join Date: Mar 2009
Location: Goldsboro
Posts: 288
M.O.C. #9143
Had the exact same issue. Ended up being corrosion on the battery ground cable. Missed it when I first checked it and ended up doing days of fruitless troubleshooting. Second time around I saw the issue, cleaned up the connections and good to go.
akf15e is offline   Reply With Quote
Old 09-20-2014, 06:15 AM   #22
TAKPAK
Montana Master
 
TAKPAK's Avatar
 
Join Date: Feb 2008
Location: Hillsboro
Posts: 568
M.O.C. #8238
Richard, we also had a 2007 3400 (purchased in 2008). If yours is like ours was, we only had ONE battery on the unit. They started putting two in at a later date. Your disconnect should be in the convenience center. What I'm seeing/hearing is absolutely no power when off the "shore". First question is, do the slides work at all, and/or does the landing gear work when off shore power (especially the landing gear). The LG is ahead of the disconnect switch, so that would tell you something if the LG works. It would pretty much rule out the battery being bad. The converter is there to power most all the items in the trailer. The battery is connected to the converter, to provide 12 volt power when disconnected from shore power. The battery also provides the power for the large load items, such as the landing gear and the slides. The converter doesn't have the "oomphf" to do those high load items, hence the need for the "high amp" battery hookup. Since you say everything works when shore power is hooked up, that leads me to believe a bad connection somewhere. I've seen connectors that look good, but the wire inside is burned up/not making contact. I would have someone inside watching the lights, and then start wiggling the main battery wires to see if the lights flicker. But, first thing is....does the landing gear work when shore is disconnected? That will rule out a couple of things.
__________________
Terry and Patsy
Vietnam Veteran, US Navy
Retired, and enjoying life
TAKPAK is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical Ski Doo General Discussions about our Montanas 16 02-18-2013 05:42 AM
Electrical randye General Discussions about our Montanas 11 01-23-2010 01:39 AM
Electrical Doug and Anita Repairs & Service 16 09-03-2006 03:13 AM
Electrical Heli 190 General Discussions about our Montanas 2 10-02-2005 07:42 AM
Electrical? MNpat General Discussions about our Montanas 3 08-20-2005 06:22 AM

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 10:37 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×