Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC Technical Forums > Montana Problems, Problem Solving & Technical Help
Click Here to Login

Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-28-2023, 04:36 PM   #1
TFIKE
New Member
 
Join Date: May 2023
Location: navarre
Posts: 4
M.O.C. #32744
Bad fuse

Hello, I had to replace a fuse in my Montana 2019/5 wheel. I changed out the 15 amp fuse, but the red light won't go out, and the lights won't come on. What am I doing wrong? Thank you.
 
TFIKE is offline   Reply With Quote
Old 08-28-2023, 07:11 PM   #2
jimcol
Montana Master
 
jimcol's Avatar
 
Join Date: Dec 2007
Location: Kansas City, Missouri
Posts: 2,700
M.O.C. #7992
Send a message via AIM to jimcol Send a message via MSN to jimcol
It sounds like it blew the new fuse you just put in. Something is on or least putting a load on that circuit or the red led will not light. You'll have to try and determine everything that is on the that fuse and turn it/them off. Then start turning items on one at a time to determine what is blowing the fuse.
__________________
2006 3000RK
2009 Ram 2500
jimcol is offline   Reply With Quote
Old 08-28-2023, 09:27 PM   #3
BB_TX
Montana Master
 
Join Date: Oct 2006
Location: McKinney
Posts: 7,113
M.O.C. #6433
I agree with jimcol. Either the new fuse was bad or it blew when you put it in. You may have seen the LED blink off and back on when you installed the fuse. That would confirm the new fuse was good but immediately blew. Sometimes you can see a flash of light from the fuse when it blows.

Was the light switch off when you installed the new fuse? And if so, was the blown fuse LED illuminated with the switch off?
__________________
Bill & Patricia
Riley, our Golden
2007 3075RL (recently sold, currently without)
BB_TX is offline   Reply With Quote
Old 08-29-2023, 09:08 AM   #4
Foldbak
Montana Master
 
Foldbak's Avatar
 
Join Date: Jan 2022
Location: Shingle Springs
Posts: 2,097
M.O.C. #30417
The original fuse blew for a reason. Usually a short circuit. If you didn't correct the short every fuse you put in will blow until the short is fixed. It might help if you provide some more information. What lights are not working?
__________________
Tony & Donna
2022 Montana HC, 295RL, Solar Flex 400, Onan 3600 LPG, 2K inverter, 200AH Lithium. 2020 GMC Denali 2500 6.6 Duramax, Demco 21K Auto Slide
Foldbak is offline   Reply With Quote
Old 09-13-2023, 08:06 PM   #5
MrMeeks
Established Member
 
Join Date: Apr 2016
Location: Huntington Beach
Posts: 18
M.O.C. #18450
Bad Fuse?

I had same problem. Fuse blew and refrigerator went out. Freaked me out. Checked everything with the fridge. Turns out, exhaust fan over stove was shorting out...and it was on same circuit as the fridge. Fixed short and fridge worked fine. Find that short. Good Luck.
MrMeeks is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 08:47 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.