Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC Technical Forums > Montana Problems, Problem Solving & Technical Help
Click Here to Login

Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-23-2022, 05:35 PM   #1
Typesteel
New Member
 
Join Date: Oct 2021
Location: Richmond
Posts: 5
M.O.C. #29931
Furnace and electric water heater

So went camping this weekend and my 2020 keystone Montana 3701lk furnace would not light. Blower starts but not furnace. Anyone know what sail switch I would need and good place to buy one? Also, electric water heater would not work. Any ideas?
 
Typesteel is offline   Reply With Quote
Old 01-24-2022, 09:33 AM   #2
Daryles
Montana Master
 
Daryles's Avatar
 
Join Date: May 2019
Location: Alton
Posts: 1,646
M.O.C. #24086
Just for giggles, swap the black 15A furnace fuse with a spare 15A regular blue one.
I discovered by accident my furnace and water heater are tied together somewhere.
I had the furnace fuse out troubleshooting, and then found out the water heater didn't work.
Put the fuse back in and the water heater started working again.
In the files section there are furnace and water heater manuals.
Hope this helps.
__________________
Daryl and Marianne,
2019 3130re 20th Anniversary Edition
2016 F350 Lariat
Daryles is offline   Reply With Quote
Old 01-24-2022, 10:13 AM   #3
Kyle and Lisa
Montana Fan
 
Join Date: May 2018
Location: livingston,tx
Posts: 490
M.O.C. #21685
Check your furnace exhaust pipe for dirt dauber nest, they are the # 1 issue with furnaces.
Kyle and Lisa is offline   Reply With Quote
Old 01-24-2022, 11:28 AM   #4
jcurtis934
Montana Master
 
Join Date: Sep 2013
Location: Pensacola (mail forward service)
Posts: 3,164
M.O.C. #13740
Unless you are comfortable working on and disassembling your furnace, leave it to a mobile tech. Have you turned off both propane tanks, taken off the gas line on the active tank, re-installed the gas line, and VERY slowly turned the tank back on...and then retired the furnace? I had a huge amount of stink bugs in the burner shield area that resulted in no heat and no error code being displayed. This requires major disassembly to just investigate and may not solve anything. On the water heater, the first thing I would do is measure for 120vac right at the element.
__________________
2012 F350 6.7 L dually, 2013 3800RE with 6 pt leveling, Sumitomo 17.5" load range h tires, Samsung 18 cu ft residential fridge, 8k Morryde I.S. with disc brakes. Full timing since 2012.
jcurtis934 is offline   Reply With Quote
Old 01-24-2022, 07:30 PM   #5
Dam Worker
Montana Master
 
Join Date: Mar 2015
Location: West Richland
Posts: 1,245
M.O.C. #17164
You probably already checked but the hot water heater has an extra on/off switch outside accessible if you remove the cover. So main switch, fuse and outside switch. As for the furnace it was already stated about the propane valve sequence and spider webs especially in the tubing. As for the sail switch I doubt that is your problem but easy to check. I chased a sail switch around for three camping trips. Turned out that my heater issue was caused by a bad motherboard which was another easy fix but a long drive out of the mountains to Clarkston to get a new one.

Tom Marty
__________________
Dam Worker is offline   Reply With Quote
Old 01-26-2022, 09:40 PM   #6
Jimbo0247
New Member
 
Join Date: Mar 2021
Location: Boaz
Posts: 5
M.O.C. #28482
I just started having the same problem with the furnace not lighting. The blower comes on for maybe a minute then stops without ignition. I followed the troubleshooting instructions in the manual, no luck. I have not changed bottles and I am sure there's gas. I full time so it's not like it has not been used. Thanks

2021 Montana 3781RL
2017 GMC 3500
Jimbo0247 is offline   Reply With Quote
Old 01-28-2022, 07:54 PM   #7
ChuckS
Montana Master
 
Join Date: Dec 2017
Location: Mountain Home
Posts: 613
M.O.C. #20949
Quote:
Originally Posted by Jimbo0247 View Post
I just started having the same problem with the furnace not lighting. The blower comes on for maybe a minute then stops without ignition. I followed the troubleshooting instructions in the manual, no luck. I have not changed bottles and I am sure there's gas. I full time so it's not like it has not been used. Thanks

2021 Montana 3781RL
2017 GMC 3500
If the blower motor runs and you hear no igniter ticking when listening outside at the furnace exhaust the usual suspect is the sail switch.. if it doesn’t close to complete the circuit the igniter won’t fire and the LP solenoid won’t open to allow gas to flow
ChuckS is offline   Reply With Quote
Old 01-28-2022, 08:08 PM   #8
Bad Moon
Montana Fan
 
Bad Moon's Avatar
 
Join Date: Apr 2016
Location: Medford
Posts: 480
M.O.C. #18546
Check the propane regulator(s); had to replace mine early on.
__________________
2016 Montana High Country 310RE
2020 Chevrolet Silverado 3500 HD LT CC 4x4 Duramax
Bad Moon is offline   Reply With Quote
Old 01-29-2022, 10:22 AM   #9
Jimbo0247
New Member
 
Join Date: Mar 2021
Location: Boaz
Posts: 5
M.O.C. #28482
Got it fixed, it was the sail switch. Thanks
Jimbo0247 is offline   Reply With Quote
Old 01-30-2022, 09:15 PM   #10
Bob and Jeannette
Montana Fan
 
Bob and Jeannette's Avatar
 
Join Date: Sep 2018
Location: Orlando
Posts: 338
M.O.C. #22589
I had the same problem… twice now. It is not the sail switch but as I proved last night in the cold fixing mine it is the sail switch contacts. A little sand paper on the contacts and I had heat. FYI you can’t jump the switch wires, lol, the circuit tests for open before the blower starts to verify it’s functioning, good engineering. Dielectric grease after sanding will give you a long term solution.
__________________
2020 Montana 3813ms legacy w/Paint
2017 Ram 3500 4X4 DRW Aisin Curt Q-25
Bob and Jeannette is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 08:18 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.