RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 

Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC Technical Forums > Maintenance
Click Here to Login

Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-04-2020, 07:13 PM   #21
whutfles
Montana Fan
 
whutfles's Avatar
 
Join Date: Apr 2015
Location: Omaha
Posts: 247
M.O.C. #17319
Carl - My 2010 Mountaineer convenience center looks exactly like your pic above, including the battery disconnect.
__________________
Bill Hutfles
2010 Montana Mountaineer 326 RLT
2012 Dodge Ram 3500 dually, 60 gal tank, Ride Rite Air Springs w/guages & pump
whutfles is online now   Reply With Quote
Old 11-04-2020, 07:40 PM   #22
McRod
Montana Fan
 
Join Date: Mar 2016
Location: Austin
Posts: 226
M.O.C. #18363
Quote:
Originally Posted by dfb View Post
May be a bad converter/...
Why would it be a bad converter? He said everything works fine on shore power. That's the converters job to convert AC to DC.

Most likely as others said the connection from battery to 12v fuse panel at the converter. He just has to track it down. Everyone's suggestions have been a good start.
McRod is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 05:19 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×