Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC Technical Forums > Montana Problems, Problem Solving & Technical Help
Click Here to Login

Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-25-2024, 08:51 AM   #1
Schmill
Established Member
 
Join Date: Jun 2005
Location: Peabody
Posts: 31
M.O.C. #4052
Right Brake Light/ Turn Signal Not Working

I am looking for suggestions regarding the above problem Have a 2003 3195RK that has this problem last October. Took unit to RV shop, they had it for almost three weeks, ended up dropping the belly pan, replaced wiring, resealed the belly pan, charged a fortune. Everything worked great on a 3,000 mile trip. Put unit in storage for the winter.

Was checking the rig out last week and found the right tail/turn light not working again. Put in new bulbs - still not working.

Does anyone have suggestions or workaround, am planning on a 1,500 mile trip in several weeks.

Thanks for the group's great support.

Jacob
 
Schmill is offline   Reply With Quote
Old 02-25-2024, 09:31 AM   #2
AZ Traveler
Site Team
 
AZ Traveler's Avatar
 
Join Date: Sep 2017
Location: Oro Valley
Posts: 3,920
M.O.C. #20477
It could be a bad ground connection.
__________________
Zack and Donna plus Millie and Ranger
2018 3160RL

"Life is too short to stay indoors, enjoy the ride!"
AZ Traveler is offline   Reply With Quote
Old 02-25-2024, 10:04 AM   #3
Carl n Susan
Site Team
 
Carl n Susan's Avatar
 
Join Date: Oct 2005
Location: Carmichael - CA
Posts: 7,355
M.O.C. #4831
The Tail/Brake light wiring runs back on the left side into the left tail light. There will be a junction there for the right side lights. Remove the left tail light bucket and check for 12V on both the left and right tail and brake lights.

I am assuming the left side tail and brakes lights both illuminate? The tail light circuit is common from the 7 pin plug to the rear. If the left tail is working then it is less likely the 7 pin plug (or a truck fuse) is the problem. But just to be sure, check the 7 pin plug to ensure you have 12V on the Left Brake, Right Brake and Tail Light pins.
__________________
Carl (n Susan)
There is more to life than fuel mileage.
2012 Montana 3700RL Big Sky Package towed by a 2015 Ford F350 6.7L PSD 4WD CC LWB

Carl n Susan is offline   Reply With Quote
Old 02-25-2024, 06:32 PM   #4
BB_TX
Montana Master
 
Join Date: Oct 2006
Location: McKinney
Posts: 7,154
M.O.C. #6433
I had that problem with my left side stop/turn light working sometimes and not others. My problem was the 7 pin truck connector. I had both an in bed connector and a bumper connector. Worked fine on the bumper connector. The in bed connector sometimes would not work unless I pushed xtra hard while wiggling it. I preferred to use the in bed connector so I replaced the in bed connector and no more problem.
__________________
Bill & Patricia
Riley, our Golden
2007 3075RL (recently sold, currently without)
BB_TX is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 01:44 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.