Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 

Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC Technical Forums > Montana Problems, Problem Solving & Technical Help
Click Here to Login

Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-26-2021, 07:52 AM   #1
Davekendall1@yahoo.com
Montana Fan
 
Join Date: Feb 2019
Location: Fredericksburg
Posts: 120
M.O.C. #23470
SoftStart issue

I'm having issues installing SoftStart on my 2019 330RL MHC 5er, rear AC unit. The rear AC unit on my RV is a Dometic Blizzard.

The SoftStart tech says my connections are correct, but it's not working properly. First, after several minutes running the AC compressor shuts off. Secondly, instructions say the SS green light should be glowing but I have a green AND center red light glowing ((I have meticulously checked every connection). Third, with nothing else on, current draw is 25 amps and it will not run on one 2000 watt generator (sea level altitude).

I'm waiting to hear back from the SS tech. If I can't resolve this, then I'm going to have to remove SoftStart and restore my AC wiring back to original setup. Has anyone else had this issue with a Dometic Blizzard and SS?

Something is not right. I wonder if the SS wiring diagram is correct or if the SoftStart is defective. Has anyone had this issue or anyone successfully installed SS on a Blizzard?
 
Davekendall1@yahoo.com is offline   Reply With Quote
Old 07-26-2021, 07:55 AM   #2
jsb5717
Montana Master
 
jsb5717's Avatar
 
Join Date: Mar 2019
Location: Milwaukie, OR
Posts: 817
M.O.C. #23668
No help, yet. I have ordered the MicroAir Easy Start for my Blizzard. So same AC, similar product. Hopefully it will arrive soon and I can report.
__________________

Jeff & Sandi (and Teddy - 7lb Schnorkie)
2018 Montana HC 305RL / Andersen Ultimate Hitch on B&W Ball
2012 RAM 3500 Big Horn Crew Cab 4x4 SRW / AMP Power Running Boards / Air Bags
jsb5717 is offline   Reply With Quote
Old 07-26-2021, 08:35 AM   #3
Daryles
Montana Master
 
Daryles's Avatar
 
Join Date: May 2019
Location: Alton
Posts: 1,220
M.O.C. #24086
I installed a SoftStartRV on my FRONT AC unit. Took way longer than it should have. I had to drill out one screw in the cover. After that it was pretty straight forward.

One correction in the instructions for a Dometic Blizzard NXT. MFG# H541916A721J0

(Note: this is the NON heat pump unit. I don't know if there is a difference with the wiring on the rear heat pump unit).

STEP 5. The blue compressor wire does NOT go to the K2 relay. It goes to the K1 relay.

https://www.montanaowners.com/forums...startRV&page=2

Maybe to test your softstartrv, move it to the forward AC unit and see how it runs on that one?
__________________
Daryl and Marianne,
2019 3130re 20th Anniversary Edition
2016 F350 Lariat
Daryles is offline   Reply With Quote
Old 07-26-2021, 08:38 AM   #4
mlh
Montana Master
 
Join Date: Oct 2004
Location: Salem
Posts: 6,273
M.O.C. #2283
A 2000 watt generator only puts out 1600 running watts and that is 13.3 amps. As for the red light wait on the tech to call.
Lynwood
__________________
www.harrellsprec.com
Lynwood Harrell
323 RL HC 2008 F250
mlh is offline   Reply With Quote
Old 07-26-2021, 10:36 AM   #5
432bartman
Montana Master
 
432bartman's Avatar
 
Join Date: May 2020
Location: UPLAND
Posts: 664
M.O.C. #26190
Dave, I have a 2019 3560RL with the Blizzard NXT, and I have the Micro Air Soft Starts on both A/C units. This was the wiring diagram I followed, which is on page 22 of their installation guide. Pages 22-26 is what I went by. My units also had the start up capacitors which I removed.
Attached Thumbnails
Click image for larger version

Name:	IMG-4211.jpg
Views:	13
Size:	454.9 KB
ID:	9792   Click image for larger version

Name:	IMG-4212.jpg
Views:	11
Size:	386.3 KB
ID:	9793   Click image for larger version

Name:	IMG-4213.jpg
Views:	10
Size:	358.0 KB
ID:	9794  
__________________
2019 Keystone Montana 3560RL
Truck: 2020 Chevy Silverado 2500 HD Duramax: Firestone airbags, Curt gooseneck, Anderson hitch, TST-507, Micro-Air thermostats & easy start. USMC combat vet & retired LEO. Robert, Anika, Breanna, Dylan & our dog Layla
432bartman is offline   Reply With Quote
Old 07-26-2021, 11:50 AM   #6
mhs4771
Montana Master
 
mhs4771's Avatar
 
Join Date: Dec 2009
Location: Sebring
Posts: 3,206
M.O.C. #9969
If you're drawing 25 amps with nothing else on there is a serious issue.
__________________
Michelle & Ann
2018 Chevy 3500HD High Country DRW 4X4 Crew Cab w/Duramax/Allison, Formally 2010 Montana 2955RL, Now Loaded 2016 SOB, Mor/ryde IS, Disc Brakes & Pin Box, Comfort Ride Hitch, Sailun 17.5 Tires.
mhs4771 is offline   Reply With Quote
Old 07-26-2021, 01:53 PM   #7
Creeker
Montana Fan
 
Join Date: Nov 2018
Location: Charleston
Posts: 400
M.O.C. #23094
Quote:
Originally Posted by mhs4771 View Post
If you're drawing 25 amps with nothing else on there is a serious issue.

Agreed. That's 11 to 12 amps higher than a normal 15K Btu unit.

What are you using to measure the 25amp draw? Is this only at start up or is it continuous?
__________________
2019 Montana HC 310RE
2010 Wildcat 29RLBS
2014 Ford F-350 Lariat 6.7
Creeker is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 02:40 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.