Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC Technical Forums > Montana Problems, Problem Solving & Technical Help
Click Here to Login

Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-22-2018, 11:39 AM   #1
Gettin' Our Kicks
New Member
 
Join Date: Apr 2017
Location: Livingston
Posts: 5
M.O.C. #19727
Water leak from hose connection with no hose connected

An issue has come up on our '18 3660RL that I'm trying to work through and wanted to ask you all. We're currently off-grid after being on connections for quite a while. We filled our fresh water tank and now, when the normal/fill valve is in the "normal" position, water is constantly dripping out of the hose connection port. If I put the valve in the "fill" position, the dripping stops. I thought it was related to the water pump (and maybe it actually is) but regardless of pump being on and pressure being relieved from the system, the drips keep coming. Thoughts?
 
__________________
Chad & Alison Reid
Sierra (Yellow Lab)
2018 Montana 3660RL Legacy
2017 Ford F350 King Ranch Ultimate
Gettin' Our Kicks is offline   Reply With Quote
Old 08-22-2018, 01:30 PM   #2
DQDick
Site Team
 
DQDick's Avatar
 
Join Date: Jun 2011
Location: Wilsey
Posts: 18,654
M.O.C. #11455
Sounds to me that either some grit is caught in the check valve or it's failed for some reason. The back part of the connector (behind the convenience wall) is a check valve to prevent that from happening. Since the rig is new, it's a warranty issue, but not hard or very expensive to fix on your own.
__________________
Dick, Joyce, Diego, Picatso and Gustav
2017 3720 RL, and 2013 HC 343RL
Pullrite Hitch, IS, Disk Brakes, 3rd AC, Winegard Traveler, Bathroom door mod, Dometic 320, couch for desk swap, replaced chairs, sun screens, added awnings, etc.
DQDick is offline   Reply With Quote
Old 08-22-2018, 01:40 PM   #3
1retired06
Montana Master
 
Join Date: Feb 2012
Location: Lake Gaston
Posts: 8,605
M.O.C. #12156
Sounds like Valve failure to me as well.
__________________
Mike and Lorraine
2002 3655 FL, 2005 3650RK
2010 3665RE, 2015 3910FB
F350 crew cab dually 6.7
1retired06 is offline   Reply With Quote
Old 08-22-2018, 01:49 PM   #4
Gettin' Our Kicks
New Member
 
Join Date: Apr 2017
Location: Livingston
Posts: 5
M.O.C. #19727
Thanks, yes, that appears to be what the issue was. I removed the screen and fiddled with the valve. It appears whatever was keeping it open got flushed when I was messing with it since the dripping seems to have stopped. Glad it was something simple!
__________________
Chad & Alison Reid
Sierra (Yellow Lab)
2018 Montana 3660RL Legacy
2017 Ford F350 King Ranch Ultimate
Gettin' Our Kicks is offline   Reply With Quote
Reply

Tags
fresh water, hose connection, water pump

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 02:49 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.