Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC on M.A.R.S. > Montana Problems, Problem Solving & Technical Help
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 10-17-2020, 12:06 PM   #21
AZ Traveler
Montana Master
 
AZ Traveler's Avatar
 
Join Date: Sep 2017
Location: Oro Valley
Posts: 2,205
M.O.C. #20477
If the pump has been dry for a while you might try priming it with a little water or maybe just replace the pump. Pumps are pretty inexpensive. Has the pump been working to pull water out of the tank?
__________________
Zack and Donna plus Millie and Ranger
2018 Montana 3160RL
2012 F-250
"Life is too short to stay indoors, enjoy the ride!"
AZ Traveler is offline   Reply With Quote
Old 10-17-2020, 12:16 PM   #22
JABURKHOLDER
Montana Master
 
JABURKHOLDER's Avatar
 
Join Date: May 2016
Location: Cuyahoga Falls
Posts: 563
M.O.C. #18572
Quote:
Originally Posted by AZ Traveler View Post
Has the pump been working to pull water out of the tank?
Never used for that purpose. Almost 18 years RV’ing and never boondocked. Only used for winterizing. Looking to trade-in next spring and don’t want a non-functioning pump to decrease value.
__________________
ATC/NAC Jerry A. Burkholder, USN (RET.)

Rule #1. The Chief is always right.
Rule #2. When in doubt, refer to rule #1.
JABURKHOLDER is offline   Reply With Quote
Old 10-17-2020, 08:25 PM   #23
Texan
Montana Master
 
Join Date: May 2017
Location: new caney
Posts: 1,050
M.O.C. #19873
Quote:
Originally Posted by JABURKHOLDER View Post
Junk mail
Telemarketers
Yard work
Understanding the wife
I am sure there are answers for the 1st 3 but anybody who says they have the answer to the 4th one is lying
Texan is offline   Reply With Quote
Old 10-17-2020, 09:59 PM   #24
kencare
Established Member
 
Join Date: Oct 2009
Location: Medicine Hat
Posts: 31
M.O.C. #9836
It only took me about 4 years to figure out that the pump can't pull the check valve in/open in the winterize connection, but the cone washer pushes in/open and the pump draws the antifreeze just like it draws water from the fresh water tank.
Try it, very simple and easy to do, you may be surprised as I was.
kencare is offline   Reply With Quote
Old 10-18-2020, 06:30 AM   #25
RMcNeal
Montana Master
 
RMcNeal's Avatar
 
Join Date: Oct 2019
Location: Jacksonville
Posts: 510
M.O.C. #25165
OK, I'm going to take one more stab at this. If all else is not the issue, then the pump impeller may be bad. I am not sure if you can disassemble it and replace or you have to replace the pump. Most I've seen are not serviceable and must be replaced.
It sounds like the pump is not drawing directly at the inlet on the pump housing, in which case, the impeller is not sealing enough to create a suction. Could be worn out or even dry rotted.
__________________
Robert & Diana McNeal
2019 Montana Legacy 3791RD 20th Anniversary Edition
2014 F350 4x4 6.7L SRW
RMcNeal is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 06:06 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×