Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > GENERAL DISCUSSIONS > Brrr it's cold outside! Winter Camping
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 01-25-2020, 10:29 PM   #1
Ohioken7
Established Member
 
Join Date: Apr 2019
Location: Rossford
Posts: 34
M.O.C. #23846
Atwood furnace only runs 3 minutes

First times using the Atwood furnace in our 2019 372rd. It runs for 3 minutes, warm air, then the fire shuts off. The blower continues a minute or so more I guess to cool it down. I read another post about thermostat wires under a dome but I havenít found that I have it. It is very consistent at 3 minutes so I donít think it could be the getting warm and shutting off. Any suggestions?
__________________
Ken & Margaret
2019 372RD
2019 F450
Ohioken7 is offline   Reply With Quote
Old 01-26-2020, 07:13 AM   #2
jimcol
Montana Master
 
jimcol's Avatar
 
Join Date: Dec 2007
Location: Kansas City
Posts: 1,897
M.O.C. #7992
Send a message via AIM to jimcol Send a message via MSN to jimcol
Have you set your thermostat to a higher temperature to see if it stays on longer?
__________________
2006 3000RK
2009 Ram 2500
jimcol is offline   Reply With Quote
Reply

Tags
cycling, furnace

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 06:49 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×