Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > GENERAL DISCUSSIONS > Full Timing in your Montana
Click Here to Login

 
 
Thread Tools Search this Thread Display Modes
 
Prev Previous Post   Next Post Next
Old 02-22-2023, 09:26 PM   #1
04montana5
Established Member
 
Join Date: Feb 2023
Location: Aguanga
Posts: 16
M.O.C. #32326
No water from hose, low pressure from tank

Hi folks I have a 2004 Montana 3575RL. I recently had an issue with the hot water pressure and got some great advice and help here in the forum. I emptied my hot water tank, flushed out tank with a wand. Tons of calsified debris came loose. I put a new anode rod in. Put some vinegar in my holding tank, flushed the whole system. Emptied and flushed the hot water tank again. My pressure was like never before. But today the pressure was a bit low and I went and connected the hose directly to get some pressure to wash dishes and no water is coming through any of the faucets. What could be going on now?
04montana5 is offline   Reply With Quote
 

Tags
3575rl, low pressure, no water from hose

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 12:42 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.