Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > GENERAL DISCUSSIONS > General Discussions about our Montanas
Click Here to Login

Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-26-2023, 08:56 AM   #1
GrahamLock
Seasoned Camper
 
Join Date: Oct 2019
Location: Canmore
Posts: 54
M.O.C. #25190
Furnace not lighting up

We have a 2019 3120RL and recently the furnace stopped working. When I turn it on via the Dometic thermostat, the fan comes on as it should, but the furnace does not light. I reset the thermostat to factory settings, and that didn't solve the problem. The fan comes on, runs for a bit, then shuts off, then on again, etc. Yesterday it worked fine. Today the above. Any ideas?
 
GrahamLock is offline   Reply With Quote
Old 03-26-2023, 10:22 AM   #2
AZ Traveler
Site Team
 
AZ Traveler's Avatar
 
Join Date: Sep 2017
Location: Oro Valley
Posts: 3,622
M.O.C. #20477
Graham,

Here is a troubleshooting guide load in the files section: https://www.montanaowners.com/forums...?do=file&id=11

Sounds like a sail switch or gas flow issue.
__________________
Zack and Donna plus Millie and Ranger
2018 3160RL

"Life is too short to stay indoors, enjoy the ride!"
AZ Traveler is offline   Reply With Quote
Old 03-26-2023, 11:36 AM   #3
DQDick
Site Team
 
DQDick's Avatar
 
Join Date: Jun 2011
Location: Wilsey
Posts: 18,784
M.O.C. #11455
I'd bet on the sail switch, common issue.
__________________
Dick, Joyce, Diego, Picatso and Gustav
2017 3720 RL, and 2013 HC 343RL
Pullrite Hitch, IS, Disk Brakes, 3rd AC, Winegard Traveler, Bathroom door mod, Dometic 320, couch for desk swap, replaced chairs, sun screens, added awnings, etc.
DQDick is offline   Reply With Quote
Old 03-26-2023, 11:54 AM   #4
GrahamLock
Seasoned Camper
 
Join Date: Oct 2019
Location: Canmore
Posts: 54
M.O.C. #25190
Furnace Issues

Thanks all. I will return the unit to the dealer to replace whatever isn't working.
GrahamLock is offline   Reply With Quote
Old 03-26-2023, 12:57 PM   #5
Daryles
Montana Master
 
Daryles's Avatar
 
Join Date: May 2019
Location: Alton
Posts: 2,257
M.O.C. #24086
Classic sail switch symptoms.
Here's a YouTube video showing how to remove and clean it.


However, sometimes it's a bad black 15A self resetting furnace fuse.
Try swapping it with a regular blue 15A one first.

If that doesn't work, remove and clean the sail switch.

If you determine it's bad here's the info to order a new one.
New sail switch kit part number 33082 which replaces old part number 33063.
Dometic part number 33082

https://www.amazon.com/33082-sail-Sw...95095564&psc=1
__________________
Daryl and Marianne,
2019 3130re 20th Anniversary Edition
2016 F350 Lariat
Daryles is offline   Reply With Quote
Old 03-26-2023, 04:48 PM   #6
GrahamLock
Seasoned Camper
 
Join Date: Oct 2019
Location: Canmore
Posts: 54
M.O.C. #25190
Furnace Issues

Quote:
Originally Posted by AZ Traveler View Post
Graham,

Here is a troubleshooting guide load in the files section: https://www.montanaowners.com/forums...?do=file&id=11

Sounds like a sail switch or gas flow issue.
Thanks to all for the suggestions. I'm still under warranty and headed home, so I'll get the dealer to fix it.
GrahamLock is offline   Reply With Quote
Old 04-02-2023, 01:19 PM   #7
GreG L.
Montana Fan
 
Join Date: Jun 2018
Location: Jacksonville
Posts: 373
M.O.C. #21993
Had the same issue, turned out to be the thermal auto reset (Black 15 amp) fuse in the fuse box (there are two), was tripping too early. Replaced it with a blue 15 amp and fixed the issue.
__________________
I was once intelligent beyond my years. Now, Iím years beyond my intelligence.
2020 Montana 3561 Legacy, everything except paint.
2018 Silverado 3500 DRW, 50Gal Transfer Flow, Andersen hitch.
GreG L. is offline   Reply With Quote
Old 04-02-2023, 01:36 PM   #8
Majorpolk
Established Member
 
Join Date: Jun 2017
Location: Greenville
Posts: 26
M.O.C. #19958
I am predicting an igniter issue.
Majorpolk is offline   Reply With Quote
Old 04-03-2023, 08:04 AM   #9
katp2
New Member
 
Join Date: Jun 2019
Location: Bushnell
Posts: 7
M.O.C. #24362
I was out in New Mexico and I could hear mine clicking but not lightning, turned out to be the gap in the igniter. Works great now!
katp2 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 11:24 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.