Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > GENERAL DISCUSSIONS > General Discussions about our Montanas
Click Here to Login

Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-18-2021, 12:00 AM   #1
edinfl
New Member
 
Join Date: Jul 2021
Location: Delray Beach
Posts: 1
M.O.C. #29222
Inverter is not getting any power (or so it seems)

The other day we noticed that out inverter on our new 2021 Montana HC was not working as auto leveler isn't working and it appears to be powered by the batteries and inverter (I think). But no matter, there is no power and my guess is that the batteries are dead, even though my panel says they are not (backup systems during power outages don't seem to be working).



When checking the inverter, the GFCI will not reset (GFCI on the inverter), no lights, appears as if there is no power coming in. Can't tell which fuse or breaker may be connected so checked them all on the control panel and also hit the Wizard Mode Button to see if that might help.



My gut says it has never been on, as I've never noticed any activity from it in the past (it's installed in our front storage compartment). Battery switch has been in the green, but have tried turning it Actuator Out.


We use this fifth wheel on a perm spot in an RV resort, so difficult to transport to a dealer. I read several threads on similar issues but not in a brand new unit. Any thoughts on what we might be able to try? Thanks.
 
edinfl is offline   Reply With Quote
Old 07-18-2021, 04:58 AM   #2
RMcNeal
Montana Master
 
RMcNeal's Avatar
 
Join Date: Oct 2019
Location: Jacksonville
Posts: 1,454
M.O.C. #25165
First thing I would try is to disconnect battery. Wait about 1 hour to allow it to equalize then test with volt meter, not at panel. Should read 12.4 to 12.6 volts. If less than that, battery needs charged. If it reads good, then reconnect and trace wires through circuit breaker, mine is 50 amp self resetting, to disconnect, then to the back of inverter in the basement. If you have power through all of these, then power at back of inverter, then inverter may have failed. We have the Magnum Dimensions CSW1012 inverter. You can get the manual with troubleshooting info from their website. https://www.magnum-dimensions.com/pr...ter-csw-series.
__________________
Robert & Diana McNeal
2019 Montana Legacy 3791RD 20th Anniversary Edition
2014 F350 4x4 6.7L SRW
RMcNeal is online now   Reply With Quote
Old 07-18-2021, 05:00 AM   #3
RMcNeal
Montana Master
 
RMcNeal's Avatar
 
Join Date: Oct 2019
Location: Jacksonville
Posts: 1,454
M.O.C. #25165
Just re-read. Your cables that feed the inverter should come through the wall of the front battery compartment. Should be easy to back trace them to the disconnect and the breaker. If there is no power on and the inverter is not running, the GFCI will not reset. That's normal, so it may still not be the GFCI. If the inverter powers up, try unplugging before resetting the GFCI.
__________________
Robert & Diana McNeal
2019 Montana Legacy 3791RD 20th Anniversary Edition
2014 F350 4x4 6.7L SRW
RMcNeal is online now   Reply With Quote
Old 07-18-2021, 06:19 AM   #4
rames14
Montana Master
 
rames14's Avatar
 
Join Date: Aug 2004
Location: Livermore
Posts: 4,576
M.O.C. #1920
First, your inverter changes 12v to 120v. Your leveling system works on 12v. So if neither are working, that sounds like no battery. Your battery shut off in the convenience bay “does not” cut power to the level up. So, you either have dead batteries or a wiring issue. My guess is dead batteries. As Robert said, start with the easy check. Use a multimeter and check your battery voltage. Once you know you have good batteries we can help from there.
__________________
Ron and Terrie Ames with Sirius - MOC #1920
2021Montana 3230CK Super Solar Legacy Package
2021 Ram 3500 Laramie Longhorn, BIM Charging
4x4, SRW, LB, Crew Cab, Pullrite 3900 Hitch
rames14 is offline   Reply With Quote
Old 07-18-2021, 06:57 AM   #5
RipNC
Montana Fan
 
Join Date: Aug 2020
Location: Aurora
Posts: 295
M.O.C. #26926
Look at your inverter and see if there is a small orange (trigger) wire going to it. My Magnum 2000 watt inverter in our 2021 3121RL has this wire and if it doesn't send 12V to the inverter the inverter won't come on when shorepower drops out. I learned this while troubleshooting a charging issue and had the battery disconnect (switch) off and the inverter still had power direct from batteries but would not produce 120V power. Not sure where the 12v trigger is supplied (didn't trace it since turning the main switch on (in convenience center) solved the problem.

The trigger could be bypassed with a simple fused jumper from the 12v input on the other end of the inverter to the terminal at the orange wire - this would let the inverter run even when the battery disconnect is in off position.
__________________
Rip & Beth
2021 3121RL Legacy Cobalt FBP
2020 F350 PSD CCLB SRW
RipNC is offline   Reply With Quote
Old 07-18-2021, 03:13 PM   #6
rohrmann
Montana Master
 
rohrmann's Avatar
 
Join Date: Oct 2012
Location: Box Elder
Posts: 3,951
M.O.C. #12947
I think before any advise can be offered, the model of the trailer needs to be said. Also, it really seems like he is talking about the converter, not an inverter, so that also needs to be confirmed.
__________________
Bob & Becky
2012 3402RL
2012 Chevy 2500HD D/A CC 4WD
rohrmann is offline   Reply With Quote
Old 01-24-2022, 08:27 PM   #7
Boondockboomer
Seasoned Camper
 
Join Date: May 2021
Location: Raleigh
Posts: 51
M.O.C. #28754
He’s definitely talking about inverter. Probably a CSW 1012 1000 watt. Fairly standard. Two plugs on front with two GFCI. IN the back black and red wire connected going through the wall to a cut off switch, down to a 150 amp breaker and straight to battery. Sound about right.
I have the same issue. Volt meter shows 14.2 volts before and after 150 amp breaker and also to back of inverter. Probably all zeroes in the front just like pic attached. If this is your case, then most likely CSW inverter is done for.
Attached Thumbnails
Click image for larger version

Name:	D62081D2-7C10-45B8-8D6B-9AB4605A4C17.jpg
Views:	11
Size:	179.8 KB
ID:	11112  
Boondockboomer is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 06:30 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.