Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC Technical Forums > Repairs & Service
Click Here to Login

Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-27-2022, 01:49 PM   #1
JayT_B
Established Member
 
Join Date: Jul 2022
Location: Fairview
Posts: 11
M.O.C. #31291
Hydraulic Leveling Control Panel, etc.

About two weeks ago, I turned on the the gray and black water tank heaters. the blue switches lit up. Last week I went to raise the front landing gear just a bit. The panel would not turn on. Today I noticed our factory installed Jaboni Solar charge control panel also will not power on. The blue tank heater switches are no longer illuminated. This is the first time we have ever used the tank heaters. Is it possible the tank heaters could have malfunctioned and somehow taken out the power to the hydraulic panel for the jacks as well as the solar charge control panel?
 
__________________
Jace - USAF Veteran
-2007 Dodge 2500 Mega Cab, CTD, 4x4, Laramie, Auto
-2020 Montana 3701LK & 2017 Arctic Fox 25W
-Yamaha EF3000iSEB Generator
JayT_B is offline   Reply With Quote
Old 11-28-2022, 12:33 PM   #2
Arkware
Montana Fan
 
Join Date: Aug 2015
Location: Mena
Posts: 493
M.O.C. #17723
sounds to me that your batteries may have been drained.
check the battery voltage.
__________________
Ron & Rhonda
2021 3230CK Montana Legacy w/ Super SolarFlex
(old rig) 2015 Montana 3611RL 8K I.S., Disk Brakes, Sailun Tires
2015 F350 XLT Crew Dually 20K B&W Companion
Arkware is offline   Reply With Quote
Old 11-28-2022, 01:25 PM   #3
JayT_B
Established Member
 
Join Date: Jul 2022
Location: Fairview
Posts: 11
M.O.C. #31291
Thank you for responding. I am guessing the battery failure is still possible even while plugged in to shore power for the last five months? We recently sold our house and moved into the Montana full time.


Thanks.
__________________
Jace - USAF Veteran
-2007 Dodge 2500 Mega Cab, CTD, 4x4, Laramie, Auto
-2020 Montana 3701LK & 2017 Arctic Fox 25W
-Yamaha EF3000iSEB Generator
JayT_B is offline   Reply With Quote
Old 11-28-2022, 03:48 PM   #4
AZ Traveler
Site Team
 
AZ Traveler's Avatar
 
Join Date: Sep 2017
Location: Oro Valley
Posts: 3,465
M.O.C. #20477
Jace,

What is the voltage on your battery bank?
__________________
Zack and Donna plus Millie and Ranger
2018 3160RL

"Life is too short to stay indoors, enjoy the ride!"
AZ Traveler is offline   Reply With Quote
Old 11-29-2022, 05:42 AM   #5
RMcNeal
Montana Master
 
RMcNeal's Avatar
 
Join Date: Oct 2019
Location: Jacksonville
Posts: 1,803
M.O.C. #25165
Quote:
Originally Posted by JayT_B View Post
Thank you for responding. I am guessing the battery failure is still possible even while plugged in to shore power for the last five months? We recently sold our house and moved into the Montana full time.


Thanks.
Battery failure is possible if your converter is not charging the batteries.
I'd start by checking battery voltage, then trace power from the converter to the batteries with shore power applied to make sure it is charging.
__________________
Robert & Diana McNeal
2019 Montana Legacy 3791RD 20th Anniversary Edition
2014 F350 4x4 6.7L SRW
RMcNeal is offline   Reply With Quote
Old 11-29-2022, 08:25 AM   #6
Daryles
Montana Master
 
Daryles's Avatar
 
Join Date: May 2019
Location: Alton
Posts: 2,091
M.O.C. #24086
Does any other 12v appliance work?
Ceiling LED lights are 12v.
The fuse for the Level-up control panel and tank heaters is a red inline fuse above the hydraulic motor in the corner. Check it. If good make sure it is pushed in all the way. Push hard.
__________________
Daryl and Marianne,
2019 3130re 20th Anniversary Edition
2016 F350 Lariat
Daryles is offline   Reply With Quote
Old 11-29-2022, 10:20 AM   #7
JayT_B
Established Member
 
Join Date: Jul 2022
Location: Fairview
Posts: 11
M.O.C. #31291
Measured the voltage of the batteries and they batteries have given up. Oddly enough, my neighbor reminded me last night he had mentioned to us just about four or five months ago he thought the batteries were on their way out. I had completely forgotten about him saying anything. I'll get those replaced and continue checking other items several of you have mentioned.


@Daryles - I was under the impression that the 12v appliances would still work when plugged in to shore power as you are getting the DC power from the converter regardless if the batteries are good or not?
__________________
Jace - USAF Veteran
-2007 Dodge 2500 Mega Cab, CTD, 4x4, Laramie, Auto
-2020 Montana 3701LK & 2017 Arctic Fox 25W
-Yamaha EF3000iSEB Generator
JayT_B is offline   Reply With Quote
Old 11-29-2022, 12:17 PM   #8
Foldbak
Montana Master
 
Foldbak's Avatar
 
Join Date: Jan 2022
Location: Shingle Springs
Posts: 1,022
M.O.C. #30417
If the batteries are dead the converter is still trying to charge them. The converter may be over worked and unable to supply power to the lights. You could have a shorted cell in one of the batteries effecting the converter. Chances are replace the and problem solved. Slides and hydraulics require charged batteries.
__________________
Tony & Donna
2022 Montana High Country 295RL, Solar Flex 400, Onan 3600 LPG, 2000 Dimensions inverter
2020 GMC Denali 2500 6.6 Duramax, Demco 21K Auto Slide
Foldbak is offline   Reply With Quote
Old 11-29-2022, 12:39 PM   #9
JayT_B
Established Member
 
Join Date: Jul 2022
Location: Fairview
Posts: 11
M.O.C. #31291
Thank you Tony. DC appliances have been working since I realized the hydraulic panel, etc were no longer operational. I am under the same inclination that replacing the batteries are going to solve some issues.
__________________
Jace - USAF Veteran
-2007 Dodge 2500 Mega Cab, CTD, 4x4, Laramie, Auto
-2020 Montana 3701LK & 2017 Arctic Fox 25W
-Yamaha EF3000iSEB Generator
JayT_B is offline   Reply With Quote
Old 11-29-2022, 04:35 PM   #10
Daryles
Montana Master
 
Daryles's Avatar
 
Join Date: May 2019
Location: Alton
Posts: 2,091
M.O.C. #24086
Jay, you are correct, if your converter is working you will have 12v lights, and furnace etc. which is a good thing (converter works).
However the hydraulic system pump may not. It requires high amps (>80A) to run.
You can take the old batteries to any auto parts store and they will test them.

You would think the Level-up control panel would at least light up. Did you check that fuse above the hydraulic motor in the corner?
__________________
Daryl and Marianne,
2019 3130re 20th Anniversary Edition
2016 F350 Lariat
Daryles is offline   Reply With Quote
Old 11-29-2022, 05:08 PM   #11
JayT_B
Established Member
 
Join Date: Jul 2022
Location: Fairview
Posts: 11
M.O.C. #31291
Daryl, We have a skirt installed, enclosing the front where the hitch is, storage during the winter. I had put everything back in its place until I get replacement batteries. Not easy wrangling an 800lb smoker in and out of that area. I will check the fuse once I have the batteries and back in that compartment. 35 degrees out now and raining. Piss poor timing, but isn't it always.
__________________
Jace - USAF Veteran
-2007 Dodge 2500 Mega Cab, CTD, 4x4, Laramie, Auto
-2020 Montana 3701LK & 2017 Arctic Fox 25W
-Yamaha EF3000iSEB Generator
JayT_B is offline   Reply With Quote
Old 11-29-2022, 07:05 PM   #12
Daryles
Montana Master
 
Daryles's Avatar
 
Join Date: May 2019
Location: Alton
Posts: 2,091
M.O.C. #24086
Yeah, that fused backed out on us while camping in January. Blue tank heater lights didn't work and the Level-up control panel did not light up either.
Someone here told me where the fuse was. Checked it, good, pushed it back down hard.
Everything was working again including the Level-up control panel.
__________________
Daryl and Marianne,
2019 3130re 20th Anniversary Edition
2016 F350 Lariat
Daryles is offline   Reply With Quote
Old 11-29-2022, 11:42 PM   #13
rohrmann
Montana Master
 
rohrmann's Avatar
 
Join Date: Oct 2012
Location: Box Elder
Posts: 4,231
M.O.C. #12947
I didn't see it mentioned, but you also must make sure your battery disconnect switch is on, and that is when the red handle can not be pulled out from the switch. If the switch is off, your converter can not get power to the batteries.
__________________
Bob & Becky
2012 3402RL
2012 Chevy 2500HD D/A CC 4WD
rohrmann is online now   Reply With Quote
Old 12-02-2022, 11:48 AM   #14
JayT_B
Established Member
 
Join Date: Jul 2022
Location: Fairview
Posts: 11
M.O.C. #31291
Thanks to all who helped out. The two new batteries did the trick and so far everything is working as it should. Old battery voltage readings, 3.6v and 2.65.
__________________
Jace - USAF Veteran
-2007 Dodge 2500 Mega Cab, CTD, 4x4, Laramie, Auto
-2020 Montana 3701LK & 2017 Arctic Fox 25W
-Yamaha EF3000iSEB Generator
JayT_B is offline   Reply With Quote
Old 12-02-2022, 03:17 PM   #15
RMcNeal
Montana Master
 
RMcNeal's Avatar
 
Join Date: Oct 2019
Location: Jacksonville
Posts: 1,803
M.O.C. #25165
That's really low! Were they 6 volt batteries?
The last ones I had that were dead in my truck and the wife's SUV were at 8 and 9 volts.
__________________
Robert & Diana McNeal
2019 Montana Legacy 3791RD 20th Anniversary Edition
2014 F350 4x4 6.7L SRW
RMcNeal is offline   Reply With Quote
Old 12-02-2022, 03:24 PM   #16
JayT_B
Established Member
 
Join Date: Jul 2022
Location: Fairview
Posts: 11
M.O.C. #31291
They were the 12v Centennial DC24MF. I could not believe it either when I had originally checked the voltage.
__________________
Jace - USAF Veteran
-2007 Dodge 2500 Mega Cab, CTD, 4x4, Laramie, Auto
-2020 Montana 3701LK & 2017 Arctic Fox 25W
-Yamaha EF3000iSEB Generator
JayT_B is offline   Reply With Quote
Old 12-05-2022, 04:38 PM   #17
carlmich1
New Member
 
Join Date: Apr 2019
Location: Brier
Posts: 4
M.O.C. #23803
Quote:
Originally Posted by JayT_B View Post
About two weeks ago, I turned on the the gray and black water tank heaters. the blue switches lit up. Last week I went to raise the front landing gear just a bit. The panel would not turn on. Today I noticed our factory installed Jaboni Solar charge control panel also will not power on. The blue tank heater switches are no longer illuminated. This is the first time we have ever used the tank heaters. Is it possible the tank heaters could have malfunctioned and somehow taken out the power to the hydraulic panel for the jacks as well as the solar charge control panel?
There is a breaker for the jacks. Look in the front of the 5th wheel where the hydralic oil is. I am just guessing
carlmich1 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 11:43 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.