RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 

Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC Technical Forums > Maintenance
Click Here to Login

Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-17-2019, 07:45 AM   #21
jeffba
Montana Master
 
Join Date: Oct 2017
Location: Bastrop
Posts: 2,620
M.O.C. #20753
Quote:
Originally Posted by mtlakejim View Post
Got it fixed!! It was bad wire on the sail switch not making good connection with the slip on female connector (IE: someone didn't strip the wire well enough).


We went ahead and dropped $400 on AGM batteries as well. We can justify the upgrade since we are full time.
Nice easy fix. I like those
__________________
2019 20th Anniversary Edition 3701LK
B&W 20K for Ford OEM Puck
2018 Ford F-350 Lariat CCLB PSD DRW
Poke super lignum unum et diem
jeffba is offline   Reply With Quote
Old 11-17-2019, 08:32 AM   #22
mtlakejim
Montana Master
 
mtlakejim's Avatar
 
Join Date: Oct 2017
Location: Bee Branch
Posts: 2,592
M.O.C. #20693
Quote:
Originally Posted by Rsmarlow82 View Post
Decided to quit overnight plenty of gas, and fan starts but no evidence of ignition

Just stated and was running just fine Any help or suggestions greatly appreciated
I would check sail switch first. Then limit switch. For test only you can bypass them (IE: pull the quick connects off and run jumper between them). Again ONLY FOR TESTING!
__________________
James & Irene Wilson
Bee Branch, AR.
2017 Ram 1 ton diesel duallyCrew Cab/Long Bed
2018 Montana High Country 381TH Garage Full of Toys
mtlakejim is offline   Reply With Quote
Old 11-17-2019, 09:28 AM   #23
Rsmarlow82
Montana Fan
 
Join Date: Sep 2018
Location: New Castle
Posts: 105
M.O.C. #22550
Quote:
Originally Posted by mtlakejim View Post
I would check sail switch first. Then limit switch. For test only you can bypass them (IE: pull the quick connects off and run jumper between them). Again ONLY FOR TESTING!
Yes Thank you That fixed it Cleaned and back in service

Thanks again
Rsmarlow82 is offline   Reply With Quote
Old 09-30-2020, 10:26 AM   #24
webbhead64
Established Member
 
Join Date: Sep 2020
Location: Cottage Grove
Posts: 14
M.O.C. #27075
Quote:
Originally Posted by CaptnJohn View Post
I had a 2015 Cougar. 1st trip 700 miles from home I called Atwood. No help, except to provide a list of authorized mobile techs. Called an hour after mobile tech could find nothing. New Atwood tech said get a slow burn fuse. No RV dealers had them and had no idea why a furnace would need one. No auto shops carried them. Atwood sent me 2 and I ordered 2 online. Put 1 in and never a problem.
Where did you end up buying the slow burn fuse, online? I must be blind, as I'm not seeing them anywhere. Perhaps I'm searching, using wrong words
webbhead64 is offline   Reply With Quote
Old 09-30-2020, 12:53 PM   #25
CaptnJohn
Montana Master
 
Join Date: May 2017
Location: South East NC
Posts: 1,652
M.O.C. #19865
Quote:
Originally Posted by webbhead64 View Post
Where did you end up buying the slow burn fuse, online? I must be blind, as I'm not seeing them anywhere. Perhaps I'm searching, using wrong words
When I called Atwood they sent me 2. I also ordered 2 online, no idea who now it's been 5 years. Auto parts don't carry them either. Gave then to the buyer when I sold that 5er.
__________________
John & Patty
2019.5 Montana 3761FL
2019 Lariat F350 4X4 Dually
CaptnJohn is offline   Reply With Quote
Old 09-30-2020, 01:19 PM   #26
CaptnJohn
Montana Master
 
Join Date: May 2017
Location: South East NC
Posts: 1,652
M.O.C. #19865
Quote:
Originally Posted by webbhead64 View Post
Where did you end up buying the slow burn fuse, online? I must be blind, as I'm not seeing them anywhere. Perhaps I'm searching, using wrong words
Try here~~

https://www.jameco.com/z/MAX-40-Eato...n_1710864.html
__________________
John & Patty
2019.5 Montana 3761FL
2019 Lariat F350 4X4 Dually
CaptnJohn is offline   Reply With Quote
Old 09-30-2020, 04:21 PM   #27
webbhead64
Established Member
 
Join Date: Sep 2020
Location: Cottage Grove
Posts: 14
M.O.C. #27075
Quote:
Originally Posted by CaptnJohn View Post
Thanks, I'll check it out!
webbhead64 is offline   Reply With Quote
Old 09-30-2020, 04:22 PM   #28
Daryles
Montana Master
 
Daryles's Avatar
 
Join Date: May 2019
Location: Alton
Posts: 712
M.O.C. #24086
Quote:
Originally Posted by webbhead64 View Post
Where did you end up buying the slow burn fuse, online? I must be blind, as I'm not seeing them anywhere. Perhaps I'm searching, using wrong words

Try here

https://www.partzilla.com/product/polaris/2410364
Daryles is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 05:14 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×