Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC Technical Forums > Maintenance
Click Here to Login

Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-18-2022, 05:31 PM   #1
A A Ron
New Member
 
Join Date: May 2022
Location: Eugene
Posts: 7
M.O.C. #31015
Heat pump not working right after "service"

We purchased our barely used 2021 3781 last spring and it has been great. The only issue that we had was the furnace exhaust was ridiculously resonate. This wasn't an issue as the heat pump in electric mode worked great and we just used that. We took the trailer back to the dealer for some pre agreed repairs and mentioned the exhaust to them. They said they could look at it. Well they did make the furnace better by "tuning" the exhaust a bit. BUT... Our system will only run in furnace mode now. Even with outside temp showing in the 60s the furnace will kick on when electric heat is selected and nothing we do with controls will get only the heat pump to operate as it did before. I have taken it back to the dealer a couple times and gotten the same shoulder shrug. I assume that when the furnace was worked on the tech jumpered the furnace and did not remove that jumper but damned if I can find it. Any ideas of how to get the heat pump working properly again??
 
A A Ron is offline   Reply With Quote
Old 05-19-2022, 08:20 AM   #2
Arkware
Montana Fan
 
Join Date: Aug 2015
Location: Mena
Posts: 484
M.O.C. #17723
When the heat system is working properly, The heat pump and heater will work together.

When you have heat set to electric, and the Set temp on the thermostat is >3 degrees above the temp at the sensor (ambient temp), then both heat pump AND heater will come on.

Is your rig a Legacy model and have In-Command?

There may be some 'special' settings I can help you with for gas only heat.
__________________
Ron & Rhonda
2021 3230CK Montana Legacy w/ Super SolarFlex
(old rig) 2015 Montana 3611RL 8K I.S., Disk Brakes, Sailun Tires
2015 F350 XLT Crew Dually 20K B&W Companion
Arkware is offline   Reply With Quote
Old 05-19-2022, 08:26 AM   #3
A A Ron
New Member
 
Join Date: May 2022
Location: Eugene
Posts: 7
M.O.C. #31015
We do have the in command system. I have tried binging the set temp up one degree at a time in electric mode and the furnace still kicks on. I don't recall having the issue prior to the furnace work.

Thank you in advance
A A Ron is offline   Reply With Quote
Old 05-19-2022, 08:29 AM   #4
Arkware
Montana Fan
 
Join Date: Aug 2015
Location: Mena
Posts: 484
M.O.C. #17723
OK. what is the Fan setting on when you have tried the heater?
__________________
Ron & Rhonda
2021 3230CK Montana Legacy w/ Super SolarFlex
(old rig) 2015 Montana 3611RL 8K I.S., Disk Brakes, Sailun Tires
2015 F350 XLT Crew Dually 20K B&W Companion
Arkware is offline   Reply With Quote
Old 05-19-2022, 08:37 AM   #5
Arkware
Montana Fan
 
Join Date: Aug 2015
Location: Mena
Posts: 484
M.O.C. #17723
another test:
Mode = Heat
Source = Gas
Fan = Off

This should turn on furnace without heat pump fan.
__________________
Ron & Rhonda
2021 3230CK Montana Legacy w/ Super SolarFlex
(old rig) 2015 Montana 3611RL 8K I.S., Disk Brakes, Sailun Tires
2015 F350 XLT Crew Dually 20K B&W Companion
Arkware is offline   Reply With Quote
Old 05-19-2022, 09:25 AM   #6
jsb5717
Montana Master
 
jsb5717's Avatar
 
Join Date: Mar 2019
Location: Milwaukie, OR
Posts: 1,137
M.O.C. #23668
Just for fun I would be temped to take the furnace out of the mix to see if you can get the heat pump to engage. You can turn it off at the control board or pull the fuse. That might tell you something. Also, which thermostat do you have? Some of the Dometics can be finiky or glitchy.
__________________

Jeff & Sandi (and Teddy - 7lb Schnorkie)
2018 Montana HC 305RL / HW Progressive EMS / Demco Recon Hitch on B&W Ball
2012 RAM 3500 Big Horn Crew Cab 4x4 SRW / AMP Power Running Boards / Air Bags
jsb5717 is offline   Reply With Quote
Old 05-19-2022, 10:54 AM   #7
Arkware
Montana Fan
 
Join Date: Aug 2015
Location: Mena
Posts: 484
M.O.C. #17723
Here are some pictures of my heater wiring.



ASA Electronics are the ones to talk to about In-Command, AC/Heat pump operation.
(800)688-3135

One other option: (after verifying wiring)
Re Boot the whole system. Sometime it will get confused.

Disconnect AC power, remove batteries (either switch or Neg. battery post.)

Reconnect.
Attached Thumbnails
Click image for larger version

Name:	20220519_111900.jpg
Views:	9
Size:	324.1 KB
ID:	11997   Click image for larger version

Name:	20220519_111824.jpg
Views:	8
Size:	279.5 KB
ID:	11998   Click image for larger version

Name:	20220519_112323.jpg
Views:	10
Size:	290.0 KB
ID:	11999  
__________________
Ron & Rhonda
2021 3230CK Montana Legacy w/ Super SolarFlex
(old rig) 2015 Montana 3611RL 8K I.S., Disk Brakes, Sailun Tires
2015 F350 XLT Crew Dually 20K B&W Companion
Arkware is offline   Reply With Quote
Old 05-19-2022, 11:01 AM   #8
Arkware
Montana Fan
 
Join Date: Aug 2015
Location: Mena
Posts: 484
M.O.C. #17723
Download the "MyKeystone" app.

Here: https://www.keystonerv.com/mykeystone

Also, manuals and troubleshooting guides here:
https://www.keystonerv.com/owners-manuals
__________________
Ron & Rhonda
2021 3230CK Montana Legacy w/ Super SolarFlex
(old rig) 2015 Montana 3611RL 8K I.S., Disk Brakes, Sailun Tires
2015 F350 XLT Crew Dually 20K B&W Companion
Arkware is offline   Reply With Quote
Old 05-23-2022, 04:47 PM   #9
The Reycrofts
Established Member
 
Join Date: May 2020
Location: Hampton bays
Posts: 16
M.O.C. #26229
Heat Pump

So it took 2 years and alot of letters to finally get the heat pump problem fixed,
we went thru, its too cold its too hot, ect...... so finally the AC with a heat pump is not in the living room it is in the Bedroom, and was not wired to any of the thermostats.
it will be wired to the bedroom thermostat. We will see if it works when we get the unit back. I have Keystone CS and Camping world CS and Service working this issue. It should not have left the factory installed incorrectly.
The Reycrofts is offline   Reply With Quote
Old 05-24-2022, 06:25 AM   #10
ChuckS
Montana Master
 
Join Date: Dec 2017
Location: Mountain Home
Posts: 658
M.O.C. #20949
If the thermostats are wired using a CANBUS then the HP should have been on the largest zone.. typically the LR and the two blue signal wires for the furnace should be on the zone 1 roof AC control board and run down to furnace control board.

If the unit is using one thermostat or In Command to control HVAC operation then a CANBUS is in use...

If there are two separate thermostats then CANBUS is not being used
ChuckS is offline   Reply With Quote
Old 05-25-2022, 01:16 PM   #11
rames14
Montana Master
 
rames14's Avatar
 
Join Date: Aug 2004
Location: Livermore
Posts: 4,825
M.O.C. #1920
AA Ron, did you get your heat pump working again?
__________________
Ron and Terrie Ames with Sirius - MOC #1920
2021Montana 3230CK Super Solar Legacy Package
2021 Ram 3500 Laramie Longhorn, BIM Charging
4x4, SRW, LB, Crew Cab, Pullrite 3900 Hitch
rames14 is offline   Reply With Quote
Old 05-25-2022, 06:27 PM   #12
Cbrandt79
Established Member
 
Join Date: Jul 2020
Location: Franktown
Posts: 38
M.O.C. #26693
Heat pump / furnace

We have a 21 legacy 3120 and experienced similar but not exact issue. Suggest change out the 15 amp fuse that is auto reset with a standard fuse. This solved the problem for us.

Best of luck!
Cbrandt79 is offline   Reply With Quote
Old 05-26-2022, 09:58 AM   #13
A A Ron
New Member
 
Join Date: May 2022
Location: Eugene
Posts: 7
M.O.C. #31015
Thank you all for good information.

Will be digging into this over the weekend. Will update
A A Ron is offline   Reply With Quote
Old 05-26-2022, 10:20 AM   #14
A A Ron
New Member
 
Join Date: May 2022
Location: Eugene
Posts: 7
M.O.C. #31015
Quote:
Originally Posted by rames14 View Post
AA Ron, did you get your heat pump working again?
going at it this weekend
A A Ron is offline   Reply With Quote
Old 05-26-2022, 10:21 AM   #15
A A Ron
New Member
 
Join Date: May 2022
Location: Eugene
Posts: 7
M.O.C. #31015
Quote:
Originally Posted by Arkware View Post
Here are some pictures of my heater wiring.



ASA Electronics are the ones to talk to about In-Command, AC/Heat pump operation.
(800)688-3135

One other option: (after verifying wiring)
Re Boot the whole system. Sometime it will get confused.

Disconnect AC power, remove batteries (either switch or Neg. battery post.)

Reconnect.
thank you for the pics. these will help alot
A A Ron is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 11:50 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.