Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MONTANA OWNERS CLUB COMMUNITY > New Member Introductions
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 08-06-2017, 02:15 PM   #1
Jerry B
New Member
 
Join Date: Aug 2017
Location: Claude
Posts: 7
M.O.C. #20300
Send a message via AIM to Jerry B Send a message via MSN to Jerry B Send a message via Yahoo to Jerry B
2009 mountaineer 29.5.12v power

New member so this has probably been answered many times...do not seem to have 12v power anywhere. No light, no slide power, nothing. Battery new and fully charged. Battery cables correct. When not plugged into 120 I have nothing. Had 12 volt power before new battery BUT had this issue: battery ran down within hour of charging, ok I changed battery, it's charged but nothing works. (That's fully charged.) Breakers are all on and checked all fuses I can find. I'm confused. Ideas?
Jerry B is offline   Reply With Quote
Old 08-06-2017, 03:38 PM   #2
Phil P
Montana Master
 
Join Date: Mar 2011
Location: Okeechobee
Posts: 2,072
M.O.C. #11206
Hi

If you put the make and model of the trailer and your TV in your signature it would be helpful for those of us that nay have a similar trailer to tell you just where to look for fuses and circuit breakers.

Phil P
Phil P is offline   Reply With Quote
Old 08-06-2017, 04:45 PM   #3
Jerry B
New Member
 
Join Date: Aug 2017
Location: Claude
Posts: 7
M.O.C. #20300
Send a message via AIM to Jerry B Send a message via MSN to Jerry B Send a message via Yahoo to Jerry B
Guess I will have to figure where to do that Phill. Where do I go to add to signature?
__________________
JerryandJo. 2009 Mountaineer295RKD,. 2008 DODGE diesel. Texas bred and born.
Jerry B is offline   Reply With Quote
Old 08-06-2017, 04:46 PM   #4
Jerry B
New Member
 
Join Date: Aug 2017
Location: Claude
Posts: 7
M.O.C. #20300
Send a message via AIM to Jerry B Send a message via MSN to Jerry B Send a message via Yahoo to Jerry B
Sorry, looks like it showed up. Thought it was lost in space!
__________________
JerryandJo. 2009 Mountaineer295RKD,. 2008 DODGE diesel. Texas bred and born.
Jerry B is offline   Reply With Quote
Old 08-06-2017, 04:49 PM   #5
Phil P
Montana Master
 
Join Date: Mar 2011
Location: Okeechobee
Posts: 2,072
M.O.C. #11206
Hi

I just haven't had time but guess I will do it now. LOL
Phil P is offline   Reply With Quote
Old 08-06-2017, 05:04 PM   #6
Phil P
Montana Master
 
Join Date: Mar 2011
Location: Okeechobee
Posts: 2,072
M.O.C. #11206
Hi

I just updated my signature but it doesn’t seem to show yet.
__________________
2009 Montana 3665RE
2009 Duramax 3500 DRW quad cab
personal web page https://www.sallyscoffees.com
If you get a page not available then remove the "s" after HTTP
Phil P is offline   Reply With Quote
Old 08-06-2017, 05:07 PM   #7
Phil P
Montana Master
 
Join Date: Mar 2011
Location: Okeechobee
Posts: 2,072
M.O.C. #11206
looks like it's there now.
__________________
2009 Montana 3665RE
2009 Duramax 3500 DRW quad cab
personal web page https://www.sallyscoffees.com
If you get a page not available then remove the "s" after HTTP
Phil P is offline   Reply With Quote
Old 08-07-2017, 07:55 AM   #8
cw3jason
Montana Master
 
cw3jason's Avatar
 
Join Date: Apr 2015
Location: Stafford Springs
Posts: 524
M.O.C. #17256
Two things possible. check your battery cut off switch in the convenience center. it may be turned off. second, you may have arced during the install of the new battery and blown your reverse polarity fuses. these are located in the fuse panel, 2 to 4 fuses depending on amps by themselves or on the backside of the converter/charger.
__________________
Jason & Wendy
2014 Ford F-350 Lariat 6.7L PSD
2015 Keystone Montana 3711FL
cw3jason is offline   Reply With Quote
Old 08-07-2017, 03:01 PM   #9
Jerry B
New Member
 
Join Date: Aug 2017
Location: Claude
Posts: 7
M.O.C. #20300
Send a message via AIM to Jerry B Send a message via MSN to Jerry B Send a message via Yahoo to Jerry B
Thanks all. Had to have been a loose connection tho I never found which one. I wiggled and tightened all wires, now it works fine. Earlier I thought everything was tight. Double check paid off.
__________________
JerryandJo. 2009 Mountaineer295RKD,. 2008 DODGE diesel. Texas bred and born.
Jerry B is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 12:04 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.