Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC on M.A.R.S. > Repairs & Service
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 07-04-2018, 11:47 AM   #1
NCFischers
Montana Master
 
Join Date: Aug 2008
Location: New Bern
Posts: 4,158
M.O.C. #8728
Send a message via Yahoo to NCFischers
Loss of power

The switch inside the RV that controls the slides and the switches to raise the landing legs and rear stabilizers quit working. I can control all of them with my remote key fob. The switch for the awning works fine. I have a 2009 model with the first generation remote and electric landing gear. Checked fuses and repaired a couple of iffy connections to no avail. Ideas?
NCFischers is offline   Reply With Quote
Old 07-04-2018, 11:53 AM   #2
mtlakejim
Montana Master
 
mtlakejim's Avatar
 
Join Date: Oct 2017
Location: Bee Branch
Posts: 2,253
M.O.C. #20693
Might check for a loose power supply wire. Not sure if those switches operate devices directly or thru a relay. If thru relays, likely only one hot wire would be shared among them with jumpers from switch to switch. Check between the one that works and next closest

I highly recommend a volt ohm meter for anyone with an RV!!

If not bad connection between switches your getting into trace it down with the volt meter territory
__________________
James & Irene Wilson
Bee Branch, AR.
2017 Ram 1 ton diesel duallyCrew Cab/Long Bed
2018 Montana High Country 381TH Garage Full of Toys
mtlakejim is offline   Reply With Quote
Old 07-04-2018, 12:32 PM   #3
Carl n Susan
Site Team
 
Carl n Susan's Avatar
 
Join Date: Oct 2005
Location: Carmichael - CA
Posts: 4,102
M.O.C. #4831
This is not an uncommon problem with the earlier rigs. There is a "fail safe" system in the control box to prevent you using the switches and the remote at the same time (don't ask me why). It has a tendency break leaving the remote as the only operative way.

You can buy a new control box, if you can find one, for $200+
OR
Read this thread on circumventing the "fail safe"

http://www.montanaowners.com/forums/showthread.php?t=46515
__________________
Carl (n Susan) Youngren
There is more to life than fuel mileage.
2012 Montana 3700RL Big Sky Package towed by a 2015 Ford F350 6.7L PSD 4WD CC LWB

Carl n Susan is offline   Reply With Quote
Old 07-07-2018, 03:02 PM   #4
NCFischers
Montana Master
 
Join Date: Aug 2008
Location: New Bern
Posts: 4,158
M.O.C. #8728
Send a message via Yahoo to NCFischers
Ordered new control box. I'll check out the thread on the work around
NCFischers is offline   Reply With Quote
Old 08-05-2018, 01:47 PM   #5
KathyandDave
Montana Master
 
Join Date: Aug 2008
Location: Shelburne
Posts: 688
M.O.C. #8693
Send a message via MSN to KathyandDave
We had various similar issues. got the new controller. OK for a while, then the rear stabilizers would only work via the fob. Found a resetting fuse in the line, mounted above the hydraulics unit. Fuse was dead. Bypassed it with a piece of wire - all good. I promise I'll get another fuse this week.
KathyandDave is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 08:07 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×