Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC on M.A.R.S. > Montana Problems, Problem Solving & Technical Help
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 10-11-2017, 12:44 PM   #1
FLYTYR
New Member
 
Join Date: Sep 2017
Location: Farmington HIlls
Posts: 3
M.O.C. #20490
Hot water & Hot water tank SULFUR Smell

Hi,
We have RV'd for years but recently our hot water and probably the tank has smelled like sulfur. This Montna is but 4 years old. I have changed the anode with not lasting results.
Is there a way to cleanse & sanitize the Hot Water tank in my Montana?
(No I am not interested in buying a new tank or selling the whole she-bang!)
Thanks,
Flytyr
FLYTYR is offline   Reply With Quote
Old 10-11-2017, 12:50 PM   #2
Lenny K
Montana Fan
 
Join Date: Jun 2014
Location: Vancouver Island
Posts: 418
M.O.C. #14417
Instructions are in your manual and look like this:

Water Supply and Odor Local water supplies (well or city) sometimes contain high levels of sulphur or other chemicals which can causes unpleasant odors. Some, like sulphur, can be very unpleasant. Sanitizing the water system, as described and allowing the sanitizing solution to remain for a few days, should eliminate the odor.

Sanitizing the Fresh Water System Keeping the fresh water system clean and free of any potential contaminations should be a top priority. Sanitizing the system before initial use and thereafter annually, or whenever water remains unused for prolonged durations, is recommended. This will help keep the water system fresh and discourage harmful bacterial or viral growth. To sanitize your system, perform the following:
1. Drain the tank by opening the low point drains. Close the drains after water has drained.
2. Prepare a chlorine bleach solution of cup to one gallon of water for every 15 gallons of tank capacity. Example: Use 2 gallons of the solution for a 40-gallon tank. If using Ultra bleach concentrations, reduce bleach to 1/8 cup to one gallon of water.
3. Add solution to tank and fill with water. Open each faucet/fixture until a distinct chlorine odor is smelled. Close faucets and let stand 4 hours.
4. Drain system and flush with fresh water until chlorine odor and smell is gone. (If a water filter has been added, change it at this time).
__________________
Lenny and Ros
2012 Montana 3400RL, 680 Watts Solar, 4 x T-105 Trojans, Trimetric 2020, EMSHW50C
2009 Chevy Silverado 3500 LTZ Duramax 4x4 CC Dually, Banks Speed Brake

Lenny K is offline   Reply With Quote
Old 10-11-2017, 06:48 PM   #3
BB_TX
Montana Master
 
Join Date: Oct 2006
Location: McKinney
Posts: 4,057
M.O.C. #6433
After sanitizing and flushing your hot water heater system, the general recommendation is to install a zinc-aluminum anode rod. The zinc supposedly helps prevent the odor causing bacteria. Both magnesium and aluminum rods can cause the bacteria. Problem is worsened by softer water.
__________________
Bill & Patricia
& Molly (our 11 yr old Golden)
2007 3075RL
2012 F350 SRW CC LB FX4 6.7
BB_TX is offline   Reply With Quote
Old 10-11-2017, 07:34 PM   #4
FLYTYR
New Member
 
Join Date: Sep 2017
Location: Farmington HIlls
Posts: 3
M.O.C. #20490
Anode question

Thanks for the advice. It is good to be at the end of the season to get this done.

Ancillary question: Upon emptying the hot water heater between trips or after winterizing, should the anode be removed or remain installed. I have heard both opinions. (My routoine is to winterize by adding antifreeze to the water system, hot water heater included.)
Flytyr
FLYTYR is offline   Reply With Quote
Old 10-11-2017, 07:45 PM   #5
Twopetes
Montana Fan
 
Join Date: Jun 2015
Location: Beloit
Posts: 164
M.O.C. #17535
No need to pull anode after each trip, but at end of season maint it is a good idea and you will see if it needs replacement.
__________________
Steve & Lisa
2015 Montana High Country 353 RL | 2011 F-250 FX-4 Crew Cab
Firestone air bags | Reese Goosebox
Ready to live the dream
Twopetes is offline   Reply With Quote
Old 10-11-2017, 08:18 PM   #6
FLYTYR
New Member
 
Join Date: Sep 2017
Location: Farmington HIlls
Posts: 3
M.O.C. #20490
Thank you - that is my usual routine. Looks like I have some sanitizing to do.
Flytyr
FLYTYR is offline   Reply With Quote
Old 10-12-2017, 05:09 AM   #7
Ishler
Montana Master
 
Ishler's Avatar
 
Join Date: Apr 2004
Location: Ontario
Posts: 677
M.O.C. #1328
There is also another source of that smell. If you have the washer/dryer prep be sure to drain an sanitize the water lines to that area. It will give you the same smell after a year or two of not being cleaned. Ask me and others how we know.
__________________
Mike & Donna Ishler Ontario, NY KE2LU FN13
2010 3605RL XFactor TST G614's
2011 Dodge 3500 Laramie CTD 4x4 Auto 4.10s
Ishler is offline   Reply With Quote
Old 10-12-2017, 06:13 AM   #8
bethandkevin
Montana Master
 
Join Date: Mar 2012
Location: Davison
Posts: 728
M.O.C. #12331
We recently had the same issue-after using the trailer most of the season with many tanks of water and city hook ups. Then it dawned on me that I had neglected to drain off the antifreeze that was in the washer lines that we do not use. After draining them, the odor was and has remained gone. My guess is, through some sort of hot to cold transfer, some of the antifreeze made its way back to the water heater.
bethandkevin is offline   Reply With Quote
Old 10-12-2017, 09:47 AM   #9
beeje
Montana Fan
 
Join Date: Oct 2015
Location: westminster
Posts: 194
M.O.C. #17894
bethandkevin, I put valves at all the fixtures so if there is a problem with one I can turn off the valves to the leaking fixture and continue to use the rest of the plumbing.

I also do not have a washer/dryer so I put valves in the lines very close to the conveiance center and the antifreeze stays in the lines and does not mix with anything. Also I don't have to winterize those lines anymore.
beeje is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 07:38 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.