Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC on M.A.R.S. > It's a Dirty Job but Someone has to do it!
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 09-06-2017, 04:50 PM   #1
caroldee2735
Seasoned Camper
 
Join Date: Jul 2015
Location: Osage Beach
Posts: 71
M.O.C. #17665
Black water valve not closing

Of course level indicator lights don't work so I rely on toilet giving a little burp when getting full. Busy with grandkids etc I wasn't paying attention and realized it had been several weeks since I dumped black water tank. When I pulled lever nothing came out until I started flushing . I think the valve must be letting water slowly leak out. Do I need a new valve or is there something else I can try. I thought maybe paper was sticking to it it. I dumped in water softener , dawn , flushed and flushed, still doesn't seem to hold water.
caroldee2735 is offline   Reply With Quote
Old 09-06-2017, 05:45 PM   #2
DQDick
Montana Master
 
Join Date: Jun 2011
Location: Council Grove
Posts: 13,929
M.O.C. #11455
You could try getting one of those valves that you hook a garden hose to and attach it to the sewer exit, turn the hose on and backflush. If it's not a new rig, however, the odds are that you'll need a new valve.
DQDick is offline   Reply With Quote
Old 09-06-2017, 06:29 PM   #3
cw3jason
Montana Fan
 
cw3jason's Avatar
 
Join Date: Apr 2015
Location: Stafford Springs
Posts: 488
M.O.C. #17256
The valves the factory uses are junk. hard to move and will fail. Replace it with a Valterra valve
__________________
Jason & Wendy
2014 Ford F-350 Lariat 6.7L PSD
2015 Keystone Montana 3711FL
cw3jason is offline   Reply With Quote
Old 09-06-2017, 08:47 PM   #4
rohrmann
Montana Master
 
rohrmann's Avatar
 
Join Date: Oct 2012
Location: Box Elder
Posts: 1,716
M.O.C. #12947
You might try getting one of those add-on Valterra valves you install on the drain outlet where you connect your drain hose, close it and start adding water with whatever high power detergent you choose, maybe even hot water with dishwasher detergent, and run enough water into the black tank so the entire valve should be covered. Let this sit for a few days, then bring the water level up so the water is backing up almost into the toilet. Do this with the stuck valve open. Then, drain the entire tank while running more water into the toilet. Once the water has run for a while, then try closing the valve that you were unable to close all the way. You may find the TP that was keeping it from closing has dissolved and you don't need to replace the valve. We had a couple stay with us in our rig when we had it out on our shakedown trip years ago, and one of them disposed of one of those moist wipes down the toilet, which proceeded to get stuck in the valve, and no amount of water would move it. That was a quick $250 lost that the RV shop charged to remove the wipe.
__________________
Bob & Becky
2012 3402RL
2012 Chevy 2500HD D/A CC 4WD
rohrmann is offline   Reply With Quote
Old 09-06-2017, 10:07 PM   #5
caroldee2735
Seasoned Camper
 
Join Date: Jul 2015
Location: Osage Beach
Posts: 71
M.O.C. #17665
That sounds like good advice. I will try it. I read on this forum that some use rid x , might that help too?
caroldee2735 is offline   Reply With Quote
Old 09-06-2017, 10:15 PM   #6
caroldee2735
Seasoned Camper
 
Join Date: Jul 2015
Location: Osage Beach
Posts: 71
M.O.C. #17665
I have a sewer solution thing that shoots a powerful stream up into the tank. I did that several times. I have the valterra valve on end of discharge pipe. I always keep that open because if gray water. I will try closing that trying to get black water tank full .
caroldee2735 is offline   Reply With Quote
Old 09-06-2017, 10:31 PM   #7
DQDick
Montana Master
 
Join Date: Jun 2011
Location: Council Grove
Posts: 13,929
M.O.C. #11455
Many of us do use an additive. Usually something like Happy Camper or Weis, but some do use Ridx.
DQDick is offline   Reply With Quote
Old 09-07-2017, 08:54 AM   #8
speedster100
Montana Fan
 
Join Date: Jun 2015
Location: owen sound
Posts: 217
M.O.C. #17566
When I pulled mine apart a couple weeks ago I discovered the factory had not installed the valve correctly. When the cable was fully closed (pushed all the way in) the valve remained 1/3 open. I had already bought a full replacement kit so I installed it as the OEM unit is a piece of crap in comparison.

Good luck messing with it, fyi I changed the valve & cable out in less than an hour... Not a big job at all.....
speedster100 is offline   Reply With Quote
Old 09-23-2017, 06:07 AM   #9
beeje
Montana Fan
 
beeje's Avatar
 
Join Date: Oct 2015
Location: westminster
Posts: 249
M.O.C. #17894
I just got finished yesterday replacing all 3 of the junk Bristol valves with Valterra valves. The cables were routed horribly. Either way to long of short with sharp bends with none of the cables anchored in any way. Previously I had to use all my might with two hands to operate the valves. Now they can literally be opened and closed with one finger. I also moved the galley pull handle to the middle level up leg much closer to the others and easier to get to. Previously you had to be a contortionist to get to it, behind the rear tire trough the frame behind the bottom skirting.
beeje is offline   Reply With Quote
Old 09-23-2017, 08:27 AM   #10
CORattler
Montana Master
 
CORattler's Avatar
 
Join Date: Jun 2010
Location: Colorado Springs
Posts: 3,335
M.O.C. #10496
My black tank valve would not close all the way and allowed black tank contents to leak past the valve. When the valve was removed I discovered that a toss in packet had jammed between the closure blade and the seal. I replaced the valve and no longer use toss in packets. Problem solved.
__________________
2010 3150RL
LevelUp, Dual 6 volt batteries, Progressive Industries EMS HW50C, Honda EU2000i Generator, Bridgestone Duravis R250 tires, Torklift Glowstep Revolution Stairs, LED Tail lights
2015 RAM 3500 Laramie SRW LB CC Cummins 6.7L Aisin Trans B&W RVK3600
CORattler is offline   Reply With Quote
Old 09-23-2017, 11:23 AM   #11
caroldee2735
Seasoned Camper
 
Join Date: Jul 2015
Location: Osage Beach
Posts: 71
M.O.C. #17665
The new valves sound great. When I was still under warranty I thought Campers world replaced mine , whatever they did seemed to make it worse.
caroldee2735 is offline   Reply With Quote
Old 09-23-2017, 11:48 AM   #12
mhs4771
Montana Master
 
mhs4771's Avatar
 
Join Date: Dec 2009
Location: Sebring
Posts: 2,058
M.O.C. #9969
I refuse to toss in those packet, because not always does it totally dissolve. I'll cut open a corner and dump the contents into a jar or other container, add water to dissolve the contents, then add it to the back tank.
__________________
Michelle & Ann
2011 Chevy LT 3500HD DRW 4X4 Extended Cab w/Duramax/Allison, Formally 2010 Montana 2955RL, Now Loaded 2016 SOB, Mor/ryde IS, Disc Brakes & Pin Box, Comfort Ride Hitch, GY G114 17.5 Tires.
mhs4771 is offline   Reply With Quote
Old 09-23-2017, 12:36 PM   #13
caroldee2735
Seasoned Camper
 
Join Date: Jul 2015
Location: Osage Beach
Posts: 71
M.O.C. #17665
Good idea to dissolve first
caroldee2735 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 01:04 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.