Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC on M.A.R.S. > Montana Problems, Problem Solving & Technical Help
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 05-17-2018, 09:13 AM   #21
richfaa
Montana Master
 
Join Date: Jan 2005
Location: North Ridgeville
Posts: 19,209
M.O.C. #2839
The micro wave should have a fuse init.
richfaa is offline   Reply With Quote
Old 05-17-2018, 03:39 PM   #22
Royalty609
New Member
 
Join Date: May 2018
Location: Cleves
Posts: 8
M.O.C. #21755
Thank you everyone for your imput.. and sense I've tried them all sounds like I need a professional..
Royalty609 is offline   Reply With Quote
Old 05-18-2018, 02:14 PM   #23
Royalty609
New Member
 
Join Date: May 2018
Location: Cleves
Posts: 8
M.O.C. #21755
I was talking to someone and I was tell them the day I was setting up we was having storms. And the electric went out and came back on .. they was saying it's possible that could have something to do with it.
Royalty609 is offline   Reply With Quote
Old 05-18-2018, 06:59 PM   #24
richfaa
Montana Master
 
Join Date: Jan 2005
Location: North Ridgeville
Posts: 19,209
M.O.C. #2839
Quote:
Originally Posted by Royalty609 View Post
I was talking to someone and I was tell them the day I was setting up we was having storms. And the electric went out and came back on .. they was saying it's possible that could have something to do with it.
You may have experienced a surge that fried those appliances. Our PT 50C electrical management system has taken the RV off line several times because of power surges over the years.
richfaa is offline   Reply With Quote
Old 05-19-2018, 08:41 AM   #25
steves
Montana Master
 
Join Date: Feb 2003
Location: Belvidere
Posts: 1,834
M.O.C. #185
Check the ground wire in your breaker box. Could be a loose lug and not getting a good ground.
steves is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 01:07 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.