Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > GENERAL DISCUSSIONS > Tow Vehicles & Towing
Click Here to Login

Notices

Reply
 
Thread Tools Display Modes
 
Old 04-16-2019, 07:20 PM   #1
jdarwin
Established Member
 
jdarwin's Avatar
 
Join Date: May 2018
Location: Bedford
Posts: 11
M.O.C. #21728
F350 Electrical Problems

I'm putting my 2017 F350 in the shop tomorrow but wanted to get some feedback from the group. I have a 2019 3931FB. When I plug into the 7 way in the truck it doesn't seem to charge the battery. Sometimes the truck tells me the trailer is connected and other times it doesn't.

When I get to my destination there's not enough battery juice to run the jacks and slides. I tried running an extension from the truck inverter to the shoreline and it wouldn't run the slides. I checked the out put of both the 7 way and the inverter. The 7 way does have 12VDC to pin 4. However, the inverter is only producing 93VAC. On the battery side, I'm confused why the coach won't charge the battery is there is power. Since I know the inverter is not producing full power, it goes to the shop.

Any ideas on why the coach won't charge?

Thanks
jdarwin is offline   Reply With Quote
Old 04-16-2019, 08:27 PM   #2
jetskier
Montana Fan
 
jetskier's Avatar
 
Join Date: Aug 2018
Location: Minden - NV
Posts: 117
M.O.C. #22360
Quote:
Originally Posted by jdarwin View Post
I'm putting my 2017 F350 in the shop tomorrow but wanted to get some feedback from the group. I have a 2019 3931FB. When I plug into the 7 way in the truck it doesn't seem to charge the battery. Sometimes the truck tells me the trailer is connected and other times it doesn't.

When I get to my destination there's not enough battery juice to run the jacks and slides. I tried running an extension from the truck inverter to the shoreline and it wouldn't run the slides. I checked the out put of both the 7 way and the inverter. The 7 way does have 12VDC to pin 4. However, the inverter is only producing 93VAC. On the battery side, I'm confused why the coach won't charge the battery is there is power. Since I know the inverter is not producing full power, it goes to the shop.

Any ideas on why the coach won't charge?

Thanks

Squeeze the manual trailer brake lever. Apparently there's an issue with the charge line on 2017+ Superduty trucks until you activate the brakes manually.
__________________
2013 F350 Lariat Ultimate FX4 CC LB SRW
2019 3790RD 20th Anniversary Edition, 860W of solar, 2000W Inverter, 5500W Onan, Slide Awnings, 3rd AC, disc brakes, dope stereo w/ sub
2017 & 2018 Kawasaki 1500SXR, 1993 750SX, 1996 750SXi jetskis
jetskier is offline   Reply With Quote
Old 04-16-2019, 09:11 PM   #3
Pops8
Established Member
 
Join Date: May 2018
Location: Granite Falls
Posts: 21
M.O.C. #21706
Quote:
Originally Posted by jetskier View Post
Squeeze the manual trailer brake lever. Apparently there's an issue with the charge line on 2017+ Superduty trucks until you activate the brakes manually.
Is that a one time thing. Or necessary every time you hitch up?
__________________
2017 3731FL / Andersen Ultimate Hitch /
2019 F450 Lariat Ultimate 4X4 Factory pucks
Pops8 is offline   Reply With Quote
Old 04-17-2019, 05:58 AM   #4
Slow Hand
Seasoned Camper
 
Join Date: May 2015
Location: Livermore
Posts: 62
M.O.C. #17391
I don't think the truck is the problem. You have to make sure the plug is all the way in the outlet. Check the connection of the trailer wire that goes to the junction box. Mine is on the pin box. Also make sure there is a good ground for the wire on the 5er. A bad ground causes more problems than people realize.
Slow Hand is offline   Reply With Quote
Old 04-17-2019, 07:33 AM   #5
Theunz
Montana Fan
 
Join Date: Mar 2016
Location: Catoosa
Posts: 221
M.O.C. #18384
Don't hold me to this, but I thought that I read some ware that the Fords needed to add a fuse in one of the fuse blocks in order to complete the charging circuit. I might be hallucinating here, but worth googling anyway.
__________________
2015 3100RL legacy...2005 Ford F-250 CC SB. Tows like a charm!
Theunz is offline   Reply With Quote
Old 04-17-2019, 07:39 AM   #6
BB_TX
Montana Master
 
Join Date: Oct 2006
Location: McKinney
Posts: 4,864
M.O.C. #6433
I don’t think that was Ford that needed a fuse. I know I didn’t on my 2007 or 2012 F350s. It was already there from new.
__________________
Bill & Patricia

2007 3075RL
2012 F350 SRW CC LB FX4 6.7
BB_TX is offline   Reply With Quote
Old 04-17-2019, 09:26 AM   #7
Drifty1
Montana Master
 
Join Date: Jul 2009
Location: Olympia
Posts: 985
M.O.C. #9441
My thought is Ford doesn’t install the fuse in the panel. Gary Kelly had the problem of not charging and found the fuse missing. Even if you order the towing package it is not installed. This would be the first thing I would check.
__________________
2002 3295RK, Magmun Hybrid 3012 inverter with 1305 watt solar at 82 volts. Midnite Classic 150 controller
4ea. 150 AH Lifepo4 batteries , Flex Air pin box, Mor/ryde I/S,disc brakes. RF Mogul dish.
Drifty1 is offline   Reply With Quote
Old 04-17-2019, 11:43 AM   #8
carl n susan
Site Team
 
carl n susan's Avatar
 
Join Date: Oct 2005
Location: Carmichael - CA
Posts: 3,547
M.O.C. #4831
Quote:
Originally Posted by Drifty1 View Post
My thought is Ford doesn’t install the fuse in the panel. Gary Kelly had the problem of not charging and found the fuse missing. Even if you order the towing package it is not installed. This would be the first thing I would check.
As Gary subsequently learned, the 2017's and up no longer use the 12V charge line relay and circuit breaker. Their positions in the fuse panels have no circuitry to connect to. After several trips to the dealer, they finally learned about the new improved system.

All 2017 F-Super Duty vehicles equipped with a factory trailer brake controller (TBC) utilize a trailer module (TRM) which initiates the trailer charging system. For trailer charging to operate, the TRM must detect a trailer is connected and a brake pedal input before charging will be present at the trailer connector. Adding the trailer battery charge relay and fuse into the battery junction box are not required to operate trailer charging with a TRM. This is covered in Ford document SSM 46257.

Ref: https://www.etrailer.com/question-278872.html plus many other internet sources.
__________________
Carl (n Susan) Youngren
There is more to life than fuel mileage.
2012 Montana 3700RL Big Sky Package towed by a 2015 Ford F350 6.7L PSD 4WD CC LWB

carl n susan is offline   Reply With Quote
Old 04-17-2019, 03:26 PM   #9
BB_TX
Montana Master
 
Join Date: Oct 2006
Location: McKinney
Posts: 4,864
M.O.C. #6433
Thanks Carl. Good to know if I ever trade up.
__________________
Bill & Patricia

2007 3075RL
2012 F350 SRW CC LB FX4 6.7
BB_TX is offline   Reply With Quote
Old 04-17-2019, 06:36 PM   #10
jdarwin
Established Member
 
jdarwin's Avatar
 
Join Date: May 2018
Location: Bedford
Posts: 11
M.O.C. #21728
Quote:
Originally Posted by carl n susan View Post
As Gary subsequently learned, the 2017's and up no longer use the 12V charge line relay and circuit breaker. Their positions in the fuse panels have no circuitry to connect to. After several trips to the dealer, they finally learned about the new improved system.

All 2017 F-Super Duty vehicles equipped with a factory trailer brake controller (TBC) utilize a trailer module (TRM) which initiates the trailer charging system. For trailer charging to operate, the TRM must detect a trailer is connected and a brake pedal input before charging will be present at the trailer connector. Adding the trailer battery charge relay and fuse into the battery junction box are not required to operate trailer charging with a TRM. This is covered in Ford document SSM 46257.

Ref: https://www.etrailer.com/question-278872.html plus many other internet sources.
Thanks for the feedback. I had searched the forum and found the TRM postings. My problem with the 7 way stems from the truck not recognizing the trailer is plugged in. I've tried manually activating the trailer brake and putting it in gear. Sometimes the digital dash reads the trailer is connected and most times it doesn't. I'll check the ground on the truck side of the plug.

Thanks
jdarwin is offline   Reply With Quote
Reply

Tags
battery, charging problem, power problem

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 11:13 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.