Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC on M.A.R.S. > Montana Problems, Problem Solving & Technical Help
Click Here to Login

 
 
Thread Tools Display Modes
 
Prev Previous Post   Next Post Next
Old 08-14-2017, 01:26 AM   #1
Marcoiv
New Member
 
Join Date: Aug 2017
Location: Forest Grove
Posts: 5
M.O.C. #20342
Black water valve stuck...

My son and I removed the underbelly panel and located a leak right on the black water valve which I assume indicates an old seal. Certainly glad it is not a crack in the tank... However...

After taking out the bolts the valve seems free but will NOT slide out. We can't seem to separate the tank from the pipe enough to let the valve slip out. We removed the bolts on the gray water valve as well, hoping if we took that out we'd be able to move the pipe enough to pull the black water valve. No luck.

Weirdest thing... they seem free, but will just not slip out.

Anyone have this problem, or know what we're missing here... ?
Thanks!
Marcoiv is offline   Reply With Quote
 

Tags
black water tank, stuck, valve

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 12:50 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×