Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC on M.A.R.S. > Montana Problems, Problem Solving & Technical Help
Click Here to Login

Notices

Reply
 
Thread Tools Display Modes
 
Old 06-18-2019, 07:43 PM   #21
masterdrago
Montana Fan
 
masterdrago's Avatar
 
Join Date: Sep 2017
Location: Willis
Posts: 498
M.O.C. #20587
Quote:
Originally Posted by BG Montana View Post
How can I tell if the inverter is turned on? I have an on / off switch but nothing lights up when pushed.

Ours does have some lights but the fan is so quiet that I cannot hear it run. I suppose it can be checked at the output with a volt meter.
__________________
2018 Montana 3791RD
2017 Ram 3500 DRW 6.7 Cummins Aisin, B&W RVK3600
masterdrago is offline   Reply With Quote
Old 06-19-2019, 05:34 AM   #22
bad99ram
Montana Fan
 
bad99ram's Avatar
 
Join Date: May 2016
Location: Ishpeming
Posts: 189
M.O.C. #18650
There is a main power switch above the battery on the wall. Needs to be turned on also. If not on no power to inverter
bad99ram is offline   Reply With Quote
Old 06-19-2019, 06:03 AM   #23
masterdrago
Montana Fan
 
masterdrago's Avatar
 
Join Date: Sep 2017
Location: Willis
Posts: 498
M.O.C. #20587
Quote:
Originally Posted by bad99ram View Post
There is a main power switch above the battery on the wall. Needs to be turned on also. If not on no power to inverter
Good point. It's the switch in the lower left of this image.
__________________
2018 Montana 3791RD
2017 Ram 3500 DRW 6.7 Cummins Aisin, B&W RVK3600
masterdrago is offline   Reply With Quote
Old 06-19-2019, 06:17 AM   #24
mastwh
Established Member
 
Join Date: Mar 2019
Location: Delaware
Posts: 17
M.O.C. #23680
Same for our 2019 HC
__________________

William and Susan - Delaware, OH
2019 Montana High Country 331RL
B&W Patriot 18k Slider / 2018 GMC Sierra 3500HD SW
mastwh is offline   Reply With Quote
Old 06-19-2019, 07:21 AM   #25
JABURKHOLDER
Montana Fan
 
JABURKHOLDER's Avatar
 
Join Date: May 2016
Location: Cuyahoga Falls
Posts: 438
M.O.C. #18572
Anyone notice the original post is from September 2017 ?
__________________
ATC/NAC Jerry A. Burkholder, USN (RET.)

Rule #1. The Chief is always right.
Rule #2. When in doubt, refer to rule #1.
JABURKHOLDER is offline   Reply With Quote
Old 06-19-2019, 09:58 AM   #26
jimcol
Montana Master
 
jimcol's Avatar
 
Join Date: Dec 2007
Location: Kansas City
Posts: 1,791
M.O.C. #7992
Send a message via AIM to jimcol Send a message via MSN to jimcol
Quote:
Originally Posted by JABURKHOLDER View Post
Anyone notice the original post is from September 2017 ?
I noticed it but BG Montana had a question on same subject just yesterday. Looks like he got some good feedback to help in solving his issue.
__________________
2006 3000RK
2009 Ram 2500
jimcol is offline   Reply With Quote
Old 06-19-2019, 11:31 AM   #27
BG Montana
New Member
 
Join Date: Jun 2019
Location: Stafford
Posts: 5
M.O.C. #24299
Thanks everyone for the feedback. I was tracking the main switch. I ran the power line with my multimeter and think the culprit is a bad inverter. I have power going into the inverter and nothing coming out. Strange because this is a brand new camper and the inverter did not work on the maiden voyage. I would drop it off for warranty work but I have another weeklong trip starting tomorrow... I'll drop it off after the trip.
BG Montana is offline   Reply With Quote
Old 06-19-2019, 12:35 PM   #28
jeffba
Montana Master
 
Join Date: Oct 2017
Location: Bastrop
Posts: 1,827
M.O.C. #20753
reset the GFI? or maybe a bad transfer switch
__________________
2019 20th Anniversary Edition 3701LK
B&W 20K for Ford OEM Puck
2018 Ford F-350 Lariat CCLB PSD DRW
Poke super lignum unum et diem
jeffba is offline   Reply With Quote
Old 06-19-2019, 01:26 PM   #29
Twopetes
Montana Fan
 
Join Date: Jun 2015
Location: Beloit
Posts: 223
M.O.C. #17535
Couple things to check. As noted somewhere on this thread, you have to be plugged into the outlet near the inverter. Check to make sure the outlet is powered when on shore power. Are you on shore power or battery? I posted on the original thread, but our inverter was wired to the TV circuit and not the frig, so it would not work when on battery (well the TV would work!). Took a little time to figure out the wiring but it works correctly now. BUT our inverter was bad also and I had to replace it. Once I got this all straight, all works well. You should have lights on the front indicating the voltage out of the inverter. Good luck
__________________
Steve & Lisa
2015 Montana High Country 353 RL | 2011 F-250 FX-4 Crew Cab
Firestone air bags | Reese Goosebox
Ready to live the dream
Twopetes is offline   Reply With Quote
Old 06-19-2019, 01:46 PM   #30
BG Montana
New Member
 
Join Date: Jun 2019
Location: Stafford
Posts: 5
M.O.C. #24299
I used my multimeter to check the battery power going into the inverter by touching the positive and negative connections on the inverter. The reading was exactly the same as at the battery terminals. On the other side of the inverter are two plugs, an on/off switch and a status reading. At a minimum the status reading should be lit. There is nothing coming out the other side of the inverter. No lights and no power coming out of the inverter at the plugs. Power going in but not coming out means a problem with the inverter. The GFI does not pop when I push test. I imagine there is a fuze in the inverter but I didn't see it. Am I troubleshooting this incorrectly? Thanks for everyone's input and help. I'm not an electrical expert and this is my first camper with an inverter.
BG Montana is offline   Reply With Quote
Old 06-19-2019, 02:10 PM   #31
Twopetes
Montana Fan
 
Join Date: Jun 2015
Location: Beloit
Posts: 223
M.O.C. #17535
No lights and no power sounds like the inverter. Ours is different than the picture above and we have a screw in fuse on the front. Does your frig work when on shore power? This should indicate a pass thru by-pass switch system that automatically allows 110 vac to the frig circuit when on shore power to run the frig and should switch to the battery inverter when shore power is disconnected. Our by-pass worked even when the inverter was bad. My guess is the default switch position is for shore power by-pass.


You have 12 vdc power going in and nothing coming out, no lights and no fan. But the 110VAC shore power works. Sounds like an bad inverter.


If under warrantee to get a replacement, I had to "buy" the replacement from the mfg and send the old unit back. If when tested by the MFG. it was found bad, my purchase was refunded. PITA, but it worked our OK. I had my unit tested before I removed it and I knew it was bad. Do you have a good dealer that can check it for you? Wish I could be more help, but it does sound like the inverter. Good luck
__________________
Steve & Lisa
2015 Montana High Country 353 RL | 2011 F-250 FX-4 Crew Cab
Firestone air bags | Reese Goosebox
Ready to live the dream
Twopetes is offline   Reply With Quote
Old 06-20-2019, 08:47 AM   #32
Ddubya
Established Member
 
Join Date: Aug 2016
Location: Sherman
Posts: 44
M.O.C. #18941
Here is a link to your converter manual. It also has trouble shooting tips.

https://www.magnum-dimensions.com/fi...token=rHJ1rIwm
__________________
2017 Alpine 3401RS,Titan Disc,Morryde SRE 4000, 2016 Ram 3500HD Laramie SRW,LWB,4X4, Aisin transmission

Ddubya is offline   Reply With Quote
Old 06-20-2019, 02:55 PM   #33
mazboy
Montana Master
 
Join Date: Aug 2009
Location: Grand Rapids
Posts: 1,297
M.O.C. #9561
Just had to respond, gotta love it; the part where Montana did this" "The inverter was wired to the TV circuit and not the refrig."



I thought Montana was now color coding wires so they would know where they go.
mazboy is offline   Reply With Quote
Old 07-02-2019, 05:08 PM   #34
BG Montana
New Member
 
Join Date: Jun 2019
Location: Stafford
Posts: 5
M.O.C. #24299
The frig works on shore power. I connected a different inverter and it lit up fine. It will take a month or more to get a somewhat local dealer to look at the camper so I contacted Keystone. I was approved to purchase an inverter and they will pay to ship the old to Keystone. As soon as they receive the old inverter I will get reimbursed. I appreciate everyone's help!
BG Montana is offline   Reply With Quote
Old 07-02-2019, 06:23 PM   #35
Carguy1965
Established Member
 
Carguy1965's Avatar
 
Join Date: Oct 2018
Location: Monroe GA
Posts: 30
M.O.C. #22777
You have to hold the button down for a sec or two, Then it beeps and lights up. Went through the same deal with mine. If you just push it nothing happens. Got to hold it down for just a bit... I bet thats your issue..
__________________
2019 3121RL Anniversary Edition

2016 Ram 2500 4x4 6.7 CTD
Carguy1965 is offline   Reply With Quote
Old 07-03-2019, 07:16 PM   #36
BG Montana
New Member
 
Join Date: Jun 2019
Location: Stafford
Posts: 5
M.O.C. #24299
Quote:
Originally Posted by Carguy1965 View Post
You have to hold the button down for a sec or two, Then it beeps and lights up. Went through the same deal with mine. If you just push it nothing happens. Got to hold it down for just a bit... I bet thats your issue..
I tried that also. Didn't fix the problem. A new inverter shows up on Monday and I'll swap it out. I'll follow up if it fixes the problem or not.
BG Montana is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 05:35 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.