Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > GENERAL DISCUSSIONS > General Discussions about our Montanas
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 07-23-2010, 08:18 AM   #1
CamillaMichael
Montana Master
 
Join Date: Mar 2010
Location: Land O Lakes
Posts: 2,783
M.O.C. #10246
Montana Logo

There is a very nice wood inlay Montana logo on the trim board over our sofa/dinette in our 3400...the issue is that the inlay is starting to "peel." Has anyone had this issue, and if so, what did you do with it? I had intended to peel the pieces all the way off and use some elmer's wood glue to put the pieces back in place, but thought it might be a good idea to hear from any of you who may have already dealt with this.
CamillaMichael is offline   Reply With Quote
Old 07-23-2010, 09:55 AM   #2
BB_TX
Montana Master
 
Join Date: Oct 2006
Location: McKinney
Posts: 4,311
M.O.C. #6433
Don't know exactly what they look like on the 2010 model, but I would try to get Keystone to replace it. Sounds like some bad wood.
All of ours still look fine after over 3 years.
__________________
Bill & Patricia
& Molly (our 11 yr old Golden)
2007 3075RL
2012 F350 SRW CC LB FX4 6.7
BB_TX is offline   Reply With Quote
Old 07-24-2010, 11:06 AM   #3
DarMar
Montana Master
 
DarMar's Avatar
 
Join Date: Feb 2004
Location: Minnedosa
Posts: 3,815
M.O.C. #1034
After reading your post I inspected our logo and by gosh it's doing the same thing. Applied pressure to the edges and it held in place but you and I both know it won't hold for long. One of the things to put on my needs fixing list for the dealer. I imagine they will suggest replacing it with the same thing which will only be a temp fix again? My guess is that many logos out there will end up doing the same thing, too bad cause it's a nice looking logo, IMHO.
__________________
Darwin & Maureen DeBackere
Minnedosa, Manitoba, Canada
2011/3500/Silverado/4x4/DRW/Duramax
2017/3721RL/Legacy Pkg./Pressure-Pro
DarMar is offline   Reply With Quote
Old 07-25-2010, 05:40 AM   #4
VaughnMB
Established Member
 
Join Date: Dec 2009
Location: Ojai
Posts: 18
M.O.C. #9983
My 2010 3150RL is doing the same thing after only six months of ownership!
VaughnMB is offline   Reply With Quote
Old 07-25-2010, 01:49 PM   #5
Illini Trekker
Montana Master
 
Join Date: Dec 2004
Location: Newton
Posts: 978
M.O.C. #2733
Sorry to here that I thought only the outside Montana graphic peeled off. For glue I like the two part epoxy.
Illini Trekker is offline   Reply With Quote
Old 07-25-2010, 02:30 PM   #6
CORattler
Montana Master
 
CORattler's Avatar
 
Join Date: Jun 2010
Location: Colorado Springs
Posts: 3,335
M.O.C. #10496
Ours was like that when we purchased it. Will get it done under warranty but not till after camping season.
__________________
2010 3150RL
LevelUp, Dual 6 volt batteries, Progressive Industries EMS HW50C, Honda EU2000i Generator, Bridgestone Duravis R250 tires, Torklift Glowstep Revolution Stairs, LED Tail lights
2015 RAM 3500 Laramie SRW LB CC Cummins 6.7L Aisin Trans B&W RVK3600
CORattler is offline   Reply With Quote
Old 07-26-2010, 12:44 PM   #7
CamillaMichael
Montana Master
 
Join Date: Mar 2010
Location: Land O Lakes
Posts: 2,783
M.O.C. #10246
Since our dealer is in Florida and we are currently camping in Maine, it will be a while before we can get them to look at it. Will need to move quick when we get back since our one year warranty will expire shortly after we return. I am still considering just using wood glue to take care of the matter myself...having the rig in the shop for another three weeks does not appeal to me. Sorry to hear others are having the same problem.
CamillaMichael is offline   Reply With Quote
Old 08-08-2010, 01:42 AM   #8
rognperly
Established Member
 
Join Date: Jul 2010
Location: Roy
Posts: 19
M.O.C. #10558
Ours is a new 2010 3150RL that has been on the dealers lot for awhile and I noticed ours is pealing as well. When I get the time I will try to glue it back as well. Taking the trailer back to the dealer for all the minor things can be such a hassle.
rognperly is offline   Reply With Quote
Old 08-22-2010, 05:57 PM   #9
mojavemike
Montana Fan
 
Join Date: Jan 2010
Location: Apple Valley
Posts: 159
M.O.C. #9997
Had the whole slide head molding replace on mine because it was cracked. The logo looked nice but when I got the new molding replace it looked like the tech took the old logo off and siliconed ot the the new molding. It was peeling and had silcone smeared all over it. Totally unexceptable. The service manger said it came frome Keylstone like that. Go figure. Waiting for another one.
mojavemike is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MOC logo Starmaster General Discussions about our Montanas 3 08-04-2015 05:25 AM
Is the MOC logo trademarked? bethandkevin General Discussions about our Montanas 5 08-04-2013 05:00 PM
Keystone/Montana Logo Merchandise seahunter Member News 17 06-11-2012 05:26 PM
Logo Decal snfexpress Additions & Improvements 8 09-06-2011 08:48 AM
MOC Logo Copyrighted?? bullroc3 Sitting around the Campfire 4 07-08-2008 05:44 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 01:02 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.