Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC on M.A.R.S. > Maintenance
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 05-12-2011, 08:02 AM   #1
abonzer
Established Member
 
Join Date: Jul 2007
Location: Santa Ynez
Posts: 38
M.O.C. #7370
Slide Pump Hose & Relays

About six months ago I had a hydraulic line leak. At the time I was on the road so I spliced the line with a barbed inline splice with hose clamps. Handy to keep a splice in case of emergency. It held until I got back home. I was actually surprised that it held at all.
I got under the trailer last week and went through the painful process of removing the underbelly and replace the line. What an oily mess!
The line was rubbing against the frame and it caused the line to rupture. Had a new hose made, cost $98.00. New line is very heavy duty, probably overkill.
I installed the line and added transmission fluid. Upon starting up the pump to push the slides I had a new problem, the contactor (relay) held closed (sticking) keeping the pump running. Not good.
Did some research and decided to replace both contactors, one for slides out and the other for slides in. The contactor was made by White Rodgers and the ones I had have been discontinued. The replacement is White Rodgers # 120-901, or 120-907 depending on your mounting location. Found it at Allied Electronics.
Installed and now back in service.
Posting here in case others have a similar issue.
abonzer is offline   Reply With Quote
Old 05-12-2011, 03:20 PM   #2
Hooker
Montana Master
 
Join Date: Nov 2007
Location: Atlanta
Posts: 908
M.O.C. #7915
Re your new hose and it rubbing against the frame. I had the same problem and cut about a 6" piece of old hose, then sliced it on one side length wise. Then I held it open (length wise) and put it over the line that had been frayed...couple of strap ties to hold it in place.
Hooker is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Slide out pump bigmurf Additions & Improvements 7 08-14-2012 01:10 PM
Slide Pump Oil mwmartin Maintenance 15 08-04-2007 11:39 AM
Hyd Slide Hose on 3295 Dee Maintenance 15 02-15-2007 04:51 AM
slide hose bob Montana Problems, Problem Solving & Technical Help 3 10-14-2006 05:56 AM
slide pump rickety Montana Problems, Problem Solving & Technical Help 2 11-23-2005 09:10 AM

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 10:15 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×