Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC on M.A.R.S. > Montana Problems, Problem Solving & Technical Help
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 04-04-2005, 01:42 PM   #1
campbud
Montana Master
 
Join Date: Feb 2005
Location:
Posts: 1,502
M.O.C. #3142
Toliet Bowl isnt holding water/water pump

While cleaning the rv today, I noticed the toliet did not have any water in the bowl. So I put some in and went back awhile later to check it and no water again..any suggestions to get this seal working right..it held water this weekend...also does anyones water pump turn on while nothing is being used? I am thinking b/c of air in the lines? Thanks everyone.
campbud is offline   Reply With Quote
Old 04-04-2005, 02:00 PM   #2
CountryGuy
Montana Master
 
Join Date: Mar 2003
Location: Tipton
Posts: 3,646
M.O.C. #191
campbud

It is my understanding that if a pump runs with NO faucets open, that you have a leak SOMEWHERE in the system.

As far as the toilet, we have had this problem occassionally, WHEN the seals were dry, but if you used the unit this weekend, I might look for a piece of TP caught where that trap moves across when you flush.

I am sure some of the fellas will be along with some more suggestions.

Carol
CountryGuy is offline   Reply With Quote
Old 04-04-2005, 02:13 PM   #3
Charlie
Montana Master
 
Join Date: Jan 2005
Location: Cooper
Posts: 1,230
M.O.C. #3029
I'm afraid Carol is right, if your pump is coming on you need to check everything. If you think that there might be air in the lines go ahead and flow all the lines until you have good clear water, then close off the taps and see if the pump restarts again. We had a seal leak on the potty this weekend but it was only dry and after some use it started to hold water in the bowel.
Charlie is offline   Reply With Quote
Old 04-04-2005, 02:33 PM   #4
azstar
Montana Master
 
Join Date: Dec 2003
Location: Chandler
Posts: 624
M.O.C. #740
Bob & Cathy,

I think I might put on disposable gloves and clean the seal. I have in the past been able to reach into the opening and clean the seal from the top. I might lube it with some hand lotion.

I have had two pumps over the years that did as you describe. It turned out to be the pump wasn't holding pressure. It would leak back to the tank side internally, so you would never see any water anywhere.

Once I understood the problem I just left the switch off when not using water. Eventually I broke down and bought a new pump. In your case it should be covered under warranty. This may be an oportunity to up grade the pump by paying the difference for the better pump.

Hope this helps
azstar is offline   Reply With Quote
Old 04-04-2005, 02:35 PM   #5
Montana_738
Montana Fan
 
Join Date: Dec 2003
Location: Mount Carroll
Posts: 194
M.O.C. #738
Hi Campbud,

If the toilet is the only problem, (It won't hold water) I had the same problem. Talked to my dealer and he said put a rubber glove on and put some vasline on one of you fingers, make sure your pump is off, step on the toilet valve and go around the edge of the seal with the vasline. He said this should be done once a year to prevent the seal from drying up. It solved my problem immediately. Like the other folks said if the pump keeps going on and off you have a leak, or air in the line. Even if your toilet won't hold water this shouldn't turn the pump on, you have to step on the valve to fill it up or add water. Check you outside shower for leaks, if you didn't get the anti freeze in there it probably frooze and cracked.

Bill
Montana_738 is offline   Reply With Quote
Old 04-04-2005, 03:52 PM   #6
campbud
Montana Master
 
Join Date: Feb 2005
Location:
Posts: 1,502
M.O.C. #3142
It has been about 2 hours and the bowl is holding water now...I cleaned around the seal with some seal cleaner and that did the trick. I looked for leaks everywhere and I could see none so I am assuming that it was air in the lines but I will check it good on our next outing(April 16th) I think I also found the leak with the window, there was some rubber sealing that was doubled in one spot, so I cut and caulked it a bit and will see how that works. Thanks everyone for your help and suggestions..it is nice to have this forum and all of you here to ask when there is a problem.
campbud is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Water Bowl Willy Bee Pet Palace 5 09-28-2017 08:58 AM
Toilet bowl will not hold water Kitesontheroad Montana Problems, Problem Solving & Technical Help 15 06-30-2015 01:17 AM
Toliet water does not turn off! Bigboomer General Discussions about our Montanas 13 01-06-2013 09:37 AM
Water draining from toilet bowl boylanag General Discussions about our Montanas 6 09-08-2008 05:30 PM
City Water vs. Holding tank water switch? Montana_6099 Montana Problems, Problem Solving & Technical Help 11 12-07-2006 08:43 AM

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 11:38 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×