Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > GENERAL DISCUSSIONS > Tow Vehicles & Towing
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 12-20-2018, 06:07 PM   #1
jfaberna
Montana Master
 
jfaberna's Avatar
 
Join Date: Nov 2013
Location: Willow Spring, NC
Posts: 900
M.O.C. #13909
OBD code P2201- anyone besides me?

I have a 2014 Ram 3500 6.7 diesel and I get occasional OBD code P2201. It's for "NOx Sensor Circuit Range/Performance Bank 1". Normally all you see is the check engine light with no performance issues. The last time I got it was after we had been using the truck around town. I drove about 7000 miles pulling the Monty mostly and the code went away. When we got home I did the normal 67,000 mile maintenance including the EGR valve and cooler cleaning and a month later the P2201 came back.

The dealer's tech advisor says to drive it hard like I did on my last trip and see if it goes away again. I won't be travel with the RV until spring. So a number of months with the code. It's sounds easy to fix from the Youtube videos, but the part is expensive. Also not sure that is guaranteed to be the fix.

Anybody had this problem?
__________________
Jim & Martha Abernathy
2014 Montana 3402RL Level UP, Sailun S637's, TST 507, Renergy 100W solar
2014 Ram 3500 Laramie® 4x2 diesel dually crew-cab 3.73 axle, Reese R20
jfaberna is offline   Reply With Quote
Old 12-25-2018, 08:11 PM   #2
djgodden
Established Member
 
Join Date: Jan 2016
Location: Hesperia
Posts: 29
M.O.C. #18183
I have a 2012 6.7 and have gotten that one a couple times, maybe 2-3 over 6 years. I clear the error and nothing happens. I researched it one time and the fix was replacing the forward Nox sensor. My brother-in-law is a Cummins ASE master mechanic and he's advised me to not worry about it unless is is a constant CEL.

When your truck goes into Regen and you're tooling around town, make sure you keep the revs up to ~2000.
__________________
Joel and Diane

2005 Montana 2955RL, 400w Renogy Solar w/charge controller charging 4 6v 225AH for 12V at 450AH, 3000W GoPower Inverter
djgodden is offline   Reply With Quote
Old 12-25-2018, 09:21 PM   #3
jfaberna
Montana Master
 
jfaberna's Avatar
 
Join Date: Nov 2013
Location: Willow Spring, NC
Posts: 900
M.O.C. #13909
At present I can't clear the code and turn off the CEL. my mechanic says to drive it hard. It stays parked most of the time since I'm not towing til spring. I will use it go to Home Depot, etc.

It could clear up when I start towing hard again, but I hate to start a long trip with a code. It may not clean up on it's own.
__________________
Jim & Martha Abernathy
2014 Montana 3402RL Level UP, Sailun S637's, TST 507, Renergy 100W solar
2014 Ram 3500 Laramie® 4x2 diesel dually crew-cab 3.73 axle, Reese R20
jfaberna is offline   Reply With Quote
Old 01-03-2019, 03:07 PM   #4
trustymopars
Montana Fan
 
Join Date: Oct 2010
Location: Maryville
Posts: 174
M.O.C. #10812
I had that happen a couple of weeks ago on my 2014. Bought a scanner and cleared the code. We drove it about 50 miles and hasn’t reappeared. We’re towing to Florida in February, so we’ll see if it comes back on. Those sensors are stupidly expensive! JT.
trustymopars is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 06:26 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×