Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC on M.A.R.S. > Repairs & Service
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 04-29-2014, 06:46 AM   #1
JandC
Montana Master
 
Join Date: Mar 2013
Location: Cape Coral
Posts: 2,253
M.O.C. #13272
2014 Furnace Problems

Just spent 30 minutes searching this issue on MOC and educating myself. Blower comes on for about 30 seconds and furnace won't ignite, blower shuts down. No error codes on display. When this first happen a couple days ago I went to Four Winds RV which is 1/2 mile down the road. They are an authorized Keystone (Montana) dealer. They determined I did not buy the unit there and said they were 6 weeks out. Service manager encouraged me to remove my Dometic furnace and bring it to them and they would try to work it in. Needless to say that is not going to happen. Checked propane and even switched bottles. One full and one 3/4 full. Stove still works. Shut off breakers/fuses to air and furnace, turned back on. Still got fan for 30 seconds, no ignition, shuts down. Finally did system reset at thermostat. Now works fine. We are 2 weeks from pulling out for trip to Seattle. Wondering if furnace will keep working or there will be trouble down the road.
__________________
Previous: 2008 Montana 3400RL & 2014 3725RL
Current: Full Time in DP
JandC is offline   Reply With Quote
Old 04-29-2014, 07:43 AM   #2
K0LCB
Montana Master
 
Join Date: Apr 2013
Location: Los Fresnos
Posts: 2,916
M.O.C. #13395
Sounds like someone tried to work furnace without propane
K0LCB is offline   Reply With Quote
Old 04-29-2014, 09:06 AM   #3
Glenn the fifth
Montana Fan
 
Join Date: Apr 2007
Location: Silverdale
Posts: 275
M.O.C. #7117
I am guessing the "system reset" at the thermostat reset whatever was "hung up" causing you to not get propane flow. When it was trying to light did you hear the "clicking" noise of the igniter trying to light the propane? Could be either an intermittent igniter problem or potentially a thermocouple issue not allowing propane flow. With any luck it will no longer be an issue and was just a passing "gremlin". Have to love all these electronics huh? -Glenn
Glenn the fifth is offline   Reply With Quote
Old 04-29-2014, 09:22 AM   #4
Rondo
Site Team
 
Join Date: Aug 2007
Location: Omaha
Posts: 5,415
M.O.C. #7560
Joe-- It could also have been possible spider webs in the burner and any movement may have freed it enough to ignite. IF the furnace had not been lit before that could have been the problem. I guess Four Winds RV is a dealer not to contact if problems come up. You might want to contact Keystone on Four Winds attitude and the Service Managers encouraging idea!
Rondo is online now   Reply With Quote
Old 04-29-2014, 09:24 AM   #5
JandC
Montana Master
 
Join Date: Mar 2013
Location: Cape Coral
Posts: 2,253
M.O.C. #13272
At one point this morning I had the cover off outside and had checked for anything obvious....loose wires, broken connections, insect blockage, etc. While the cover was off I turned furnace Zone 1 up to 78 degrees and went back out to watch unit. I could hear it try to ignite two or three times but no go. That was all before I did the system reset at thermostat.
__________________
Previous: 2008 Montana 3400RL & 2014 3725RL
Current: Full Time in DP
JandC is offline   Reply With Quote
Old 04-29-2014, 12:21 PM   #6
jlb27537
Montana Master
 
Join Date: Jan 2013
Location: Depends on temps
Posts: 1,648
M.O.C. #13157
Jim, when it did not light did you notice a led on the ckt board blinking? If so how many blinks? When it tries to light, hold your hand on the gas valve and see if you feel a thud. If you are getting a thud at the gas valve, you hear clicking and then get a 3 blink led on the board it is sensing no flame. You will need to remove the outside cover on the furnace to see the ckt board and feel the gas solenoid. The ckt board is mounted in the top of the case, you will need to kinda look up with the outer cover off to see it.

Get back to us on more clues. The furnace is a Attwood, not a Dometic. Edited, Attwood furnace.

Jim
__________________

2012 Ram Laramie 3500 DRW 4x4 3.73 Tow Max Pkg B&W Companion 60 gal RDS aux fuel tank. 2014 Montana 3150RL, 2 A/C's, Leather, 6 Point Jacks, Splendede WD2100XC, Mor/ryde X-Factor, Duravis 250 tires with TST 507RV monitors. 2 x Honda EU2000's
jlb27537 is offline   Reply With Quote
Old 04-29-2014, 04:01 PM   #7
WeBeFulltime
Montana Master
 
WeBeFulltime's Avatar
 
Join Date: May 2011
Location: Hixson
Posts: 2,660
M.O.C. #11397
Quote:
quote:Originally posted by jlb27537



Get back to us on more clues. The furnace is a Suburban, not a Dometic.

Jim
When did Montana stop using Atwood/Excalibur furnaces and switch to Suburban furnaces?
__________________
2018.5 Montana 3791RD
2012 F350 SRW 6.7 PSD

Full Timing since September 1, 2010
WeBeFulltime is offline   Reply With Quote
Old 04-30-2014, 02:09 AM   #8
jlb27537
Montana Master
 
Join Date: Jan 2013
Location: Depends on temps
Posts: 1,648
M.O.C. #13157
Quote:
quote:Originally posted by WeBeFulltime

Quote:
quote:Originally posted by jlb27537



Get back to us on more clues. The furnace is a Suburban, not a Dometic.

Jim
When did Montana stop using Atwood/Excalibur furnaces and switch to Suburban furnaces?
My Bad, It is a Attwood. Jim
__________________

2012 Ram Laramie 3500 DRW 4x4 3.73 Tow Max Pkg B&W Companion 60 gal RDS aux fuel tank. 2014 Montana 3150RL, 2 A/C's, Leather, 6 Point Jacks, Splendede WD2100XC, Mor/ryde X-Factor, Duravis 250 tires with TST 507RV monitors. 2 x Honda EU2000's
jlb27537 is offline   Reply With Quote
Old 04-30-2014, 05:20 AM   #9
JandC
Montana Master
 
Join Date: Mar 2013
Location: Cape Coral
Posts: 2,253
M.O.C. #13272
I guess I was going by the thermostat control in the hallway, thinking the furnace was a Dometic also. That was the only paperwork we received, none specific for only the furnace. It was 40 plus degrees this morning and is only getting up to low 50's. Have played around with furnace a couple of times, turning it up to 73 and letting it heat trailer up until it turns off, then turning it back down and waiting before repeating process. So far so good, it is lighting every time and shutting off when the inside temp (as displayed on thermostat) reaches the set temp.
__________________
Previous: 2008 Montana 3400RL & 2014 3725RL
Current: Full Time in DP
JandC is offline   Reply With Quote
Old 04-30-2014, 12:50 PM   #10
PackerFan
Montana Master
 
PackerFan's Avatar
 
Join Date: Feb 2004
Location: Pahrump, Nevada
Posts: 2,518
M.O.C. #1081
Sounds like the thermostat reset did it. Hope it works out good for you.
__________________
Scott & Sue
Life long Cheeseheads & Shareholders!
2016 RAM 3500 Laramie, Dually. 2013 Montana 3725RL
PackerFan is offline   Reply With Quote
Old 04-30-2014, 02:09 PM   #11
snfexpress
Montana Master
 
Join Date: Jan 2006
Location: South
Posts: 2,499
M.O.C. #5140
I have a lot of experience with Atwood furnaces. It could be the ignitor, sail switch, Dometic thermostat or ??? Post again if you have problems, because I spent 3 days in snowy conditions figuring out why ours died.
snfexpress is offline   Reply With Quote
Old 04-30-2014, 05:36 PM   #12
CORattler
Montana Master
 
CORattler's Avatar
 
Join Date: Jun 2010
Location: Colorado Springs
Posts: 3,335
M.O.C. #10496
What is the "system reset at thermostat" procedure??? I've never heard of this. Thanks!

Quote:
quote:Originally posted by JandC

Finally did system reset at thermostat. Now works fine.
__________________
2010 3150RL
LevelUp, Dual 6 volt batteries, Progressive Industries EMS HW50C, Honda EU2000i Generator, Bridgestone Duravis R250 tires, Torklift Glowstep Revolution Stairs, LED Tail lights
2015 RAM 3500 Laramie SRW LB CC Cummins 6.7L Aisin Trans B&W RVK3600
CORattler is offline   Reply With Quote
Old 05-01-2014, 06:19 AM   #13
JandC
Montana Master
 
Join Date: Mar 2013
Location: Cape Coral
Posts: 2,253
M.O.C. #13272
[quote]Originally posted by CORattler

What is the "system reset at thermostat" procedure??? I've never heard of this. Thanks!
[quote]

Make sure thermostat is in "off" mode. Simultaneously press and hold the "Mode" and "Zone" buttons. The LCD display will display "IniT". Release the buttons. Press the "On/Off" button to exit system set up. This resets for factory settings. Since I completed this procedure everything is still working good. It is in the 40's with rain/wind today and I have ran the furnace several times just to keep testing it.
__________________
Previous: 2008 Montana 3400RL & 2014 3725RL
Current: Full Time in DP
JandC is offline   Reply With Quote
Old 05-01-2014, 08:57 AM   #14
jlb27537
Montana Master
 
Join Date: Jan 2013
Location: Depends on temps
Posts: 1,648
M.O.C. #13157
The "System Reset" is used when there is a change in the config of the system, such as adding a bedroom air. During the reset the thermostat looks at the control board in the Zone 1 A/C unit and learns what devices (heat pumps, furnaces, 2nd A/C, etc) it is supposed to control.

IF your CCC2 thermostat is replaced, loses it memory, you do a system reset. IF your CCC2 thermostat is showing you have a LP furnace, and is causing it to try and heat, it (the CCC2) is working properly. If the furnace is not operating properly you can check the LED on the furnace board for a fault code.

Manuals for most of our systems are available here for free download.
http://bryantrv.com/docs.html

Jim
__________________

2012 Ram Laramie 3500 DRW 4x4 3.73 Tow Max Pkg B&W Companion 60 gal RDS aux fuel tank. 2014 Montana 3150RL, 2 A/C's, Leather, 6 Point Jacks, Splendede WD2100XC, Mor/ryde X-Factor, Duravis 250 tires with TST 507RV monitors. 2 x Honda EU2000's
jlb27537 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Furnace problems Lone Ranger Montana Problems, Problem Solving & Technical Help 5 10-10-2011 04:09 PM
Furnace Problems RC and Samantha General Discussions about our Montanas 20 10-20-2009 10:51 AM
Furnace Problems dannyl General Discussions about our Montanas 10 11-19-2007 04:42 PM
Furnace Problems rickfox General Discussions about our Montanas 20 01-21-2007 09:57 AM
Furnace problems. flyerone Montana Problems, Problem Solving & Technical Help 1 04-21-2006 03:38 PM

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 08:54 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.