Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > GENERAL DISCUSSIONS > General Discussions about our Montanas
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 12-10-2019, 09:21 PM   #1
texasfiretech
New Member
 
Join Date: Dec 2019
Location: Roanoke
Posts: 1
M.O.C. #25458
Furrion Oven Power Issue in a 3950BR

Hello everyone,

New to the site and first post. My wife and I just bought a 2017 Montana 3950BR last weekend, and I have tried to get the Furrion oven to work. No LED lights lit up around the knobs, and the display is dark. Also no ignitor clicking. Come to find out with further investigation, our Dometic fridge quit cooling. I checked the fuses and found the kitchen slide 15 amp fuse blown. I replaced the fuse and the fridge came back on. Still no display on the oven though, I turned the left knob on the oven to try to light the oven, and I heard the 15 amp fuse blow in the fuse box. Fridge stopped working again, I replaced the fuse and the fridge started working. Did not try the oven again.

Anyone have any thoughts on what might be wrong with the Furrion oven or what to try to troubleshoot the issue? My assumptions are there is a short in the circuit. I am willing to try anything, before having a repair person come out. We just became full-timers and parked the Montana at the RV park, and do not have a truck to pull the Montana to a dealership. Thanks in advance!
texasfiretech is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 03:19 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×