Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC on M.A.R.S. > Montana Problems, Problem Solving & Technical Help
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 07-13-2018, 01:30 PM   #1
Travelling Three
Seasoned Camper
 
Join Date: Sep 2016
Location: Sioux Falls
Posts: 70
M.O.C. #19003
No Furnace

We have a 2017 Montana 3661RL. When turning on the furnace nothing happens, no fan, lots of nothing. On the ignitor board the red LED blinks once every three seconds indicating a bad air vane switch. I took the air vane switch out, measured continuity and the switch is operating properly. Before I go any further I would like some possible suggestions as to the problem. I have propane in the bottle. Were camping at 10,000 feet but the furnace has been working fine. That's for any suggestions.
Travelling Three is offline   Reply With Quote
Old 07-15-2018, 11:53 AM   #2
Travelling Three
Seasoned Camper
 
Join Date: Sep 2016
Location: Sioux Falls
Posts: 70
M.O.C. #19003
Go Huskers!
Travelling Three is offline   Reply With Quote
Old 07-15-2018, 12:23 PM   #3
carl n susan
Site Team
 
carl n susan's Avatar
 
Join Date: Oct 2005
Location: Carmichael - CA
Posts: 3,117
M.O.C. #4831
In the "Files" section (on the second brown bar above) is a RV Furnace Troubleshooting Guide which may be of assistance.
http://www.montanaowners.com/forums/...?do=file&id=11
__________________
Carl (n Susan) Youngren
There is more to life than fuel mileage.
2012 Montana 3700RL Big Sky Package towed by a 2015 Ford F350 6.7L PSD 4WD CC LWB

carl n susan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 06:38 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.