Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC on M.A.R.S. > Montana Problems, Problem Solving & Technical Help
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 09-07-2018, 04:56 AM   #1
mazboy
Montana Master
 
Join Date: Aug 2009
Location: Grand Rapids
Posts: 983
M.O.C. #9561
Fresh water diveter problem????

Last week I went camping and tried to fill my fresh water tank....and yes, the lever was in the correct position. Anyway, it would not fill.


I tried it again later at 2 other water locations--not the same place, and it still did not work.


I took it to the dealer and they called and said it worked for them though slow.


Question: has anyone had this issue? I've never seen it on this site.
And, second part, has anyone replaced their fresh water diveter valve? Dealer says the valve I have on my 2013 is no longer available, and 'for $375 we can fix that.'
mazboy is offline   Reply With Quote
Old 09-07-2018, 07:13 AM   #2
DQDick
Montana Master
 
DQDick's Avatar
 
Join Date: Jun 2011
Location: Wilsey
Posts: 15,268
M.O.C. #11455
Actually they may not be screwing you. Amazon shows one, not our type, for over $90. Add in the labor for taking the wall down and working inside all the other plumbing and it's probably what other dealers would charge. Couldn't find one pictured on Trekwood.com but I'd call them and get a price on an actually replacement and then do it myself.
__________________
Dick and Joyce, Wilsey, KS & Lakewood, NM
2017 3720 RL
2017 3500 Dodge Maxi Cab
IS and Disk Brakes, 3rd AC, Bathroom door mod, etc.
DQDick is offline   Reply With Quote
Old 09-07-2018, 12:25 PM   #3
rohrmann
Montana Master
 
rohrmann's Avatar
 
Join Date: Oct 2012
Location: Box Elder
Posts: 2,089
M.O.C. #12947
This may be the valve you are needing. http://www.trekwood.com/products/139...-2-MPT-x-1-2-P
__________________
Bob & Becky
2012 3402RL
2012 Chevy 2500HD D/A CC 4WD
rohrmann is online now   Reply With Quote
Old 09-19-2018, 06:01 AM   #4
mazboy
Montana Master
 
Join Date: Aug 2009
Location: Grand Rapids
Posts: 983
M.O.C. #9561
OK OK, i figured out the problem. My water problem was that the screen at the water intake was completely covered with crap.



what happens to us is when we stay in mexico for the winter a 'green slime' grows in the fresh water hose and gets on the screen.


problem solved at spending money and time, i only had to replace the screen.
mazboy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 08:33 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.