Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC on M.A.R.S. > Repairs & Service
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 01-21-2018, 12:54 AM   #1
MAMalody
Montana Master
 
Join Date: Jul 2006
Location: Pasco
Posts: 974
M.O.C. #5972
Replace CAP LEDs

The LEDs on one side of my front cap no longer work. How to you replace those. I can't figure out how to get them out....probably just need to open my eyes,
MAMalody is offline   Reply With Quote
Old 01-21-2018, 10:20 AM   #2
bullroc3
Montana Master
 
Join Date: Apr 2007
Location: Harford
Posts: 896
M.O.C. #7122
I replaced mine on my 2013. They are a strip with an adhesive backing. I just pulled on them from the outer edge until I reached the point where the wiring comes through the cap. There is a hole where the wiring comes through. There should be a wire connector that attaches the strip to the coach wiring. There was quite a length of it tucked in behind the cap. Seeing that you have one working and one not, I would test to see if that one has power to it.
T
__________________
bullroc3 is offline   Reply With Quote
Old 02-12-2018, 08:39 AM   #3
hickory
Montana Fan
 
Join Date: Jan 2013
Location: Jefferson,
Posts: 237
M.O.C. #13170
cap LED

I've replaced three so far. Just start from the lower end and peel the old one off. remove the old glue and caulking and stick the new one in place,making sure you make a good electrical connection and caulk the hole where the wires come through to make it completely waterproof.
hickory is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 06:22 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.