Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > GENERAL DISCUSSIONS > General Discussions about our Montanas
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old Yesterday, 07:42 PM   #1
Maggiesclan
New Member
 
Join Date: Jan 2018
Location: Meaa
Posts: 2
M.O.C. #21072
Noises from LCI leveling sysyem

Hello,

My wife and I own a 2015 Keystone Montana 3610RL Fifth Wheel, which we purchased new in Dec 2015.

We are experiencing popping noises and associated vibration which we believe is originating from the front two (of 6 ) leveling jacks.

We wondered if anyone else is experiencing this, and if so, have you found resolution?

I called the dealership where we purchased our rig. We were told they were not familiar with this complaint. It was suggested that I contact Lippert (LCI) as they are the manufacturers of the self leveling system.

Any suggestions on this would be appreciated. Thanks!
Maggiesclan is offline   Reply With Quote
Old Yesterday, 07:50 PM   #2
carl n susan
Site Team
 
carl n susan's Avatar
 
Join Date: Oct 2005
Location: Carmichael
Posts: 2,790
M.O.C. #4831
This is a well known "feature" of the level up system. Lippert has identified the problem as "stiction". There is a solution available by adding a quart or two of special (15 weight) oil. Read about the problem and solution here http://www.montanaowners.com/forums/...ad.php?t=71385
__________________
Carl (n Susan) Youngren
There is more to life than fuel mileage.
2012 Montana 3700RL Big Sky Package towed by a 2015 Ford F350 6.7L PSD 4WD CC LWB

carl n susan is offline   Reply With Quote
Old Yesterday, 09:08 PM   #3
1retired06
Montana Master
 
Join Date: Feb 2012
Location: Lake Gaston
Posts: 6,438
M.O.C. #12156
Worked for us
__________________
Mike and Lorraine
2002 3655 FL, 2005 3650RK
2010 3665RE, 2015 3910FB
F350 crew cab dually 6.7
1retired06 is offline   Reply With Quote
Old Yesterday, 09:20 PM   #4
RKassl
Montana Master
 
RKassl's Avatar
 
Join Date: May 2005
Location: Fall Creek
Posts: 1,002
M.O.C. #3699
Had exactly the same problem on our 2015, used the CAT oil and fixed it permanently.
__________________
Bob and Nancy Kassl Fall Creek, Wisconsin
2015 Montana 3440RL Legacy Edition, G614's, Pressure Pro TPMS, Dish Tailgaters
2016 GMC Sierra Denali 3500 CC SRW, Iridium Metallic, Duramax Allison Transmission
RKassl is offline   Reply With Quote
Old Yesterday, 09:34 PM   #5
Mudchief
Montana Master
 
Join Date: Nov 2005
Location: Paola
Posts: 5,210
M.O.C. #4961
It fixed ours also.
__________________
Dennis & Linda Ward
Paola, Kansas
Montana 3735MK Legacy Edition
1200 watts of Solar
Mudchief is offline   Reply With Quote
Old Yesterday, 10:37 PM   #6
Maggiesclan
New Member
 
Join Date: Jan 2018
Location: Meaa
Posts: 2
M.O.C. #21072
Noises

Thanks to those who responded. Hopefully we can get this corrected soon. Sure is annoying!! Thanks
Maggiesclan is offline   Reply With Quote
Old Today, 12:31 AM   #7
Lucky23
Established Member
 
Lucky23's Avatar
 
Join Date: Nov 2015
Location: Shady Cove
Posts: 22
M.O.C. #18031
This should help it’s Lippert service bulletin https://www.lci1.com/assets/content/...ic_Systems.pdf
__________________
2015 GMC Denali 2500hd D/A
2016 Montana 3160rl Legacy

Lucky23 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 04:22 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.