Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC on M.A.R.S. > Additions & Improvements
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 09-25-2019, 07:25 PM   #1
Skypirate
Established Member
 
Join Date: Aug 2019
Location: Littleton
Posts: 11
M.O.C. #24661
Furion back-up camera problems?

Hi everyone!
Was GREAT meeting a lot of you at the rally and we learned SO much! From our awesome Canadian neighbors; Vaugn and Teri,Don &Sue, Carl and Sandy, George,Eric,Steve,Joe and so many more of you....we've learned so much! Thanks for your "tips" and just great advise!
Teri and I had baught and had installed a back up camera from Furion which worked just fine the day it was installed but cannot get it to work "consistantly" since. We purchased it at the rally and was told it will allow us to see behind our coach while driving....well this is what I've learned...the power source will define "when you can view: reverse power source will only activate when in reverse and a driving light power source will provide power when lights are on"....contacted Furion and was told the power source "may not be a true 12 volts" so "not our problem". I metered the driving light power source and is just over 12 volts....spent almost 500 dollars for a 4" monitor that just blocks my view and has NO picture....any help?
Skypirate is offline   Reply With Quote
Old 09-25-2019, 09:32 PM   #2
jjfleck
Established Member
 
Join Date: May 2017
Location: ormond beach
Posts: 44
M.O.C. #19826
Might be a distance problem, mine would cut in and out all the time. I called furion and they gave me a "stronger model" at no charge. Worked much better since then.
jjfleck is offline   Reply With Quote
Old 09-26-2019, 06:30 AM   #3
jeffba
Montana Master
 
Join Date: Oct 2017
Location: Bastrop
Posts: 1,955
M.O.C. #20753
did you get a backup or observation camera? The observation version has a better signal.
__________________
2019 20th Anniversary Edition 3701LK
B&W 20K for Ford OEM Puck
2018 Ford F-350 Lariat CCLB PSD DRW
Poke super lignum unum et diem
jeffba is offline   Reply With Quote
Old 09-26-2019, 07:16 PM   #4
Skypirate
Established Member
 
Join Date: Aug 2019
Location: Littleton
Posts: 11
M.O.C. #24661
Believe we purchased the "observation" camera because we described what we wanted to the folks at the MOC booth and was told by Tom at Furion that there are "no differences in the cameras any more" and it all depends on the strength of the 12 volt wires we used as a power source....
Skypirate is offline   Reply With Quote
Old 09-27-2019, 05:23 AM   #5
jeffba
Montana Master
 
Join Date: Oct 2017
Location: Bastrop
Posts: 1,955
M.O.C. #20753
Have you measured the voltage under load with the camera on? If the voltage under load is within spec the issue will be with the camera.
__________________
2019 20th Anniversary Edition 3701LK
B&W 20K for Ford OEM Puck
2018 Ford F-350 Lariat CCLB PSD DRW
Poke super lignum unum et diem
jeffba is offline   Reply With Quote
Old 09-29-2019, 04:46 PM   #6
JPDoege
Established Member
 
JPDoege's Avatar
 
Join Date: Jan 2019
Location: Rockford
Posts: 28
M.O.C. #23236
Send a message via Skype™ to JPDoege
So, do you have the trailer running lights on?? What is on the screen in your truck?
__________________
Northern Illinois
2019 3790RD with Legacy package.2018 Ford F350 6.7l diesel dually.
Love building control panels for machine automation and fixing machines.
JPDoege is offline   Reply With Quote
Old 09-29-2019, 06:34 PM   #7
bleedmichigan
Established Member
 
Join Date: Apr 2019
Location: Columbia
Posts: 20
M.O.C. #23739
So I had a similar problem. I have a furion that worked great itís wired to the high light on the rear cap of our 2011 3750FL. Voltage reads over 12 then on our cross country trip it started acting wonky. Still had good voltage when sitting hard to check while moving. Tested the in bed plug and it seemed fine for the 7 pin but read lower than the bumper 7 pin. Adjusted the antenna per furion tech support guidelines and it seemed to work better then the signal died. Got to the camp site we were heading to about an hour away and started unwiring it. Tested fine. Thought it was a stupid piece of junk at that point. Left the next day and decided to plug the camper into the bumper 7 pin didnít have a problem the whole way. Took the imbed wiring out and found a really small slit in the harness. Ordered a new plug and play harness and had it amazon next day to the campground. Plug in wire tied up and gave it a try. Not a problem. I decided to slice open the harness that I pulled off and one of the wires was covered with corrosion. My guess is as it moved down the road it was shorting out just enough to not provide enough juice to the camera and to power a good signal some 40í to the monitor. So just a thought try another plug if you can like the bumper plug or adjust the antenna per the furion specs which is not straight up and down.
bleedmichigan is offline   Reply With Quote
Old 10-06-2019, 01:27 PM   #8
Fishin2dMax
Established Member
 
Join Date: Oct 2017
Location: South Jordan
Posts: 37
M.O.C. #20689
I have the Furrion observation camera on the last two 5'er's, including my HC montana. I'm not real happy with the overall picture quality, but I haven't had any issues with signal drop out and it does work for seeing what is directly behind the trailer. Since your problem appears to be intermittent, I highly doubt it is due to low voltage, rather a poor power connection or intermittent signal loss.

When the camera signal drops out, check to see if the blue LED light (illuminates on the camera when powered on) is working. With the trucks running lights on, the rear camera blue LED light should be on. If the blue LED is on, it's not a power problem to the camera.

Another possibility is the wireless signal drop out. The next time the camera doesn't show a signal, move the receiver (monitor) and antenna to see if it comes back on. The Antenna on the camera should be pointed up vertically and the antenna on the receiver / monitor should also be vertical. There is a signal strength indicator on the display that you can watch to adjust antenna to highest signal strength. If the signal is the problem, playing with the receiver and location will validate this.

If you've tried the above to no avail, it is highly possible the camera itself is intermittent. Good luck.
__________________
2018.5 Montana HC 305 RL
2019 GMC 3500 HD Denali
Fishin2dMax is offline   Reply With Quote
Old 10-06-2019, 02:21 PM   #9
Mroe
Established Member
 
Join Date: Mar 2019
Location: Scottsdale
Posts: 24
M.O.C. #23577
If it only works when in reverse, connect the power to the wire that goes to the parking lights vs the backup light, then you’ll have power to the camera when the lights are on, that’s how mine works
Mroe is offline   Reply With Quote
Old 10-06-2019, 08:57 PM   #10
cgeis48
Seasoned Camper
 
cgeis48's Avatar
 
Join Date: Mar 2009
Location: Sun Lakes
Posts: 72
M.O.C. #9174
Mine works only when the headlights or running lights are on.
__________________
Carl G
2020 Montana 3721RL
2017 Ford F250 6.7 diesel
cgeis48 is offline   Reply With Quote
Old 10-06-2019, 09:01 PM   #11
Mroe
Established Member
 
Join Date: Mar 2019
Location: Scottsdale
Posts: 24
M.O.C. #23577
Yes that’s what I meant, parking lights or head lights
Mroe is offline   Reply With Quote
Old 10-07-2019, 07:59 AM   #12
glendodom
Seasoned Camper
 
Join Date: Sep 2018
Location: Terry
Posts: 72
M.O.C. #22698
Furion Camera Issue

I have a Furion backup camera that came on our 2018 3721RL operating via a GMC PU. First, I have to have the running lights turned on to power the rear camera. Second, it worked fine when I first got it all installed than later keep going in and out and finally no picture. In the end, my issue was the rear antenna wasn't making a good connection to the camera. Check your antenna itself to ensure it is properly seated. Take it off and reinstall and see what you get. Worked for me.
glendodom is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 01:34 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×