Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC on M.A.R.S. > Repairs & Service
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 01-11-2018, 05:08 PM   #1
CaptnJohn
Montana Master
 
Join Date: May 2017
Location: Eastern NC
Posts: 1,035
M.O.C. #19865
12 volt out

CG lost power and I have no 12 volt lights either. Landing gear works. No reset buttons on the 2 near the batteries. Batteries have 12.9. Connections are tight.
Battery switches are in proper setting.
CaptnJohn is offline   Reply With Quote
Old 01-11-2018, 05:27 PM   #2
carl n susan
Site Team
 
carl n susan's Avatar
 
Join Date: Oct 2005
Location: Carmichael - CA
Posts: 3,304
M.O.C. #4831
Check your battery disconnect switch in the Convenience Center. These sounds like the classic symptoms of a disconnected battery. If the key comes out, then the battery is disconnected.
__________________
Carl (n Susan) Youngren
There is more to life than fuel mileage.
2012 Montana 3700RL Big Sky Package towed by a 2015 Ford F350 6.7L PSD 4WD CC LWB

carl n susan is offline   Reply With Quote
Old 01-11-2018, 05:31 PM   #3
Theunz
Montana Fan
 
Join Date: Mar 2016
Location: Catoosa
Posts: 144
M.O.C. #18384
Water pump or heater working? If nothing not directly connected to battery works than you might have a bad connection at the fuse panel or the battery disconnect switch. Have you tried hooking to the tow vehicle electrical?
Theunz is offline   Reply With Quote
Old 01-11-2018, 05:35 PM   #4
CaptnJohn
Montana Master
 
Join Date: May 2017
Location: Eastern NC
Posts: 1,035
M.O.C. #19865
Batt switches are correct. No waterr pump. No thermostat
CaptnJohn is offline   Reply With Quote
Old 01-11-2018, 05:41 PM   #5
CaptnJohn
Montana Master
 
Join Date: May 2017
Location: Eastern NC
Posts: 1,035
M.O.C. #19865
Nothing on inside when connected to truck either. Marker lights work so a good connection there.
CaptnJohn is offline   Reply With Quote
Old 01-11-2018, 05:55 PM   #6
rohrmann
Montana Master
 
rohrmann's Avatar
 
Join Date: Oct 2012
Location: Box Elder
Posts: 2,098
M.O.C. #12947
Sounds like your auto reset breaker behind the batteries has failed. We have two, one has several wires feeding loads independent of the main electric panel, and the other has two large wires, one to the hydraulic pump and the other to the electric panel via the disconnect switch. My money is on the cheap breaker.
__________________
Bob & Becky
2012 3402RL
2012 Chevy 2500HD D/A CC 4WD
rohrmann is offline   Reply With Quote
Old 01-11-2018, 06:02 PM   #7
CaptnJohn
Montana Master
 
Join Date: May 2017
Location: Eastern NC
Posts: 1,035
M.O.C. #19865
Quote:
Originally Posted by rohrmann View Post
Sounds like your auto reset breaker behind the batteries has failed. We have two, one has several wires feeding loads independent of the main electric panel, and the other has two large wires, one to the hydraulic pump and the other to the electric panel via the disconnect switch. My money is on the cheap breaker.
Nothing to do tonight with that. It has not reset ~~ about 30 minutes and no reset buttons on them.
CaptnJohn is offline   Reply With Quote
Old 01-11-2018, 07:20 PM   #8
Theunz
Montana Fan
 
Join Date: Mar 2016
Location: Catoosa
Posts: 144
M.O.C. #18384
I would check voltage at fuse panel inside trailer first, if nothing there I would go to battery disconnect next. Might try banging on both places and see if lights flicker first. Got to be a bad connection somewhere.
Theunz is offline   Reply With Quote
Old 01-11-2018, 08:52 PM   #9
CaptnJohn
Montana Master
 
Join Date: May 2017
Location: Eastern NC
Posts: 1,035
M.O.C. #19865
Quote:
Originally Posted by Theunz View Post
I would check voltage at fuse panel inside trailer first, if nothing there I would go to battery disconnect next. Might try banging on both places and see if lights flicker first. Got to be a bad connection somewhere.
Hit them with the flashlight. Had to quit before I got the hammer. Tomorrow I'll try replacing the breakers by the batteries 1st.
CaptnJohn is offline   Reply With Quote
Old 01-11-2018, 08:57 PM   #10
rohrmann
Montana Master
 
rohrmann's Avatar
 
Join Date: Oct 2012
Location: Box Elder
Posts: 2,098
M.O.C. #12947
Quote:
Originally Posted by CaptnJohn View Post
Nothing to do tonight with that. It has not reset ~~ about 30 minutes and no reset buttons on them.
They are not a manual reset breaker. All they have in them is a bi-metal link that makes or breaks the connection. If it is burnt, the contact will not complete the connection. The only way to fix them is replacement, because they are a throw away part.
Attached Images
File Type: jpg auto-reset breaker.jpg (110.3 KB, 124 views)
__________________
Bob & Becky
2012 3402RL
2012 Chevy 2500HD D/A CC 4WD
rohrmann is offline   Reply With Quote
Old 01-12-2018, 07:57 AM   #11
CaptnJohn
Montana Master
 
Join Date: May 2017
Location: Eastern NC
Posts: 1,035
M.O.C. #19865
Raining hard now but will get 2, one to go in and a spare.
CaptnJohn is offline   Reply With Quote
Old 01-12-2018, 08:46 AM   #12
Ram Montana High Country
Montana Fan
 
Ram Montana High Country's Avatar
 
Join Date: Jun 2017
Location: POINTBLANK
Posts: 409
M.O.C. #19944
Unwire and test with meter. Us Shore Power available?
__________________
RAM 305RL HC EAST TEXAS
Ram Montana High Country is offline   Reply With Quote
Old 01-12-2018, 08:56 AM   #13
CaptnJohn
Montana Master
 
Join Date: May 2017
Location: Eastern NC
Posts: 1,035
M.O.C. #19865
Quote:
Originally Posted by Ram Montana High Country View Post
Unwire and test with meter. Us Shore Power available?
Shore power is available NOW. A transformer blew at the corner and put 1/3 of the CG out. When all went black is when I knew I had a problem. Raining now ~~ will get at it soon.
CaptnJohn is offline   Reply With Quote
Old 01-12-2018, 10:43 AM   #14
CaptnJohn
Montana Master
 
Join Date: May 2017
Location: Eastern NC
Posts: 1,035
M.O.C. #19865
Batteries not charging beyond 12.9. Maybe the darn converter,,, still raining!
CaptnJohn is offline   Reply With Quote
Old 01-19-2018, 02:44 PM   #15
masterdrago
Montana Fan
 
masterdrago's Avatar
 
Join Date: Sep 2017
Location: Willis
Posts: 424
M.O.C. #20587
Have not heard back from you CaptnJohn. What did you find?
__________________
2018 Montana 3791RD
2017 Ram 3500 DRW 6.7 Cummins Aisin, B&W RVK3600
masterdrago is offline   Reply With Quote
Old 01-19-2018, 05:36 PM   #16
CaptnJohn
Montana Master
 
Join Date: May 2017
Location: Eastern NC
Posts: 1,035
M.O.C. #19865
Quote:
Originally Posted by masterdrago View Post
Have not heard back from you CaptnJohn. What did you find?
Had to get a mobile tech. Found a wire problem between the shutoff in the convenience center and converter. I never use that one as I installed a total cutoff near the batteries. He brought a new converter to replace under warranty and traced back after finding the one installed good. $45 service call did it.
CaptnJohn is offline   Reply With Quote
Old 01-20-2018, 09:20 AM   #17
mhs4771
Montana Master
 
mhs4771's Avatar
 
Join Date: Dec 2009
Location: Sebring
Posts: 2,291
M.O.C. #9969
A few years ago I noticed some funny readings on 12Vs and flickering lights. Found the cables connected to the Battery Shut-off switch were only finger tight with one the nut about to fall off. Tightened and every thing was fine.
__________________
Michelle & Ann
2018 Chevy 3500HD High Country DRW 4X4 Crew Cab w/Duramax/Allison, Formally 2010 Montana 2955RL, Now Loaded 2016 SOB, Mor/ryde IS, Disc Brakes & Pin Box, Comfort Ride Hitch, GY G114 17.5 Tires.
mhs4771 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 06:22 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.