Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > GENERAL DISCUSSIONS > General Discussions about our Montanas
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 11-07-2018, 03:00 PM   #1
wprantera
New Member
 
Join Date: May 2017
Location: Bruce Twp.
Posts: 9
M.O.C. #19790
Heat Pump Issue

Has anyone had an issue with their rear heat pump? During a Halloween camping weekend weather was chilly but not below freezing, so I decided to just you the rear AC heat pump. My issue is that it was all ice up when I went up to the roof tut o check for debris on the slides. See attached pictures. Do I have a problem?
wprantera is offline   Reply With Quote
Old 11-07-2018, 07:16 PM   #2
CarWin
Montana Fan
 
Join Date: Jan 2018
Location: Thornville
Posts: 319
M.O.C. #21110
Quote:
Originally Posted by wprantera View Post
Has anyone had an issue with their rear heat pump? During a Halloween camping weekend weather was chilly but not below freezing, so I decided to just you the rear AC heat pump. My issue is that it was all ice up when I went up to the roof tut o check for debris on the slides. See attached pictures. Do I have a problem?
YES you have a problem.............There is NO pictures attached for us to see.
__________________
Darwin & Carla
2018.5 3701LK Montana
2016 2500HD Duramax
CarWin is offline   Reply With Quote
Old 11-08-2018, 07:04 AM   #3
jimcol
Montana Master
 
jimcol's Avatar
 
Join Date: Dec 2007
Location: Kansas City
Posts: 1,691
M.O.C. #7992
Send a message via AIM to jimcol Send a message via MSN to jimcol
If your heat pump was iced up there is a problem. I'm confident of that even without a picture.
__________________
2006 3000RK
2009 Ram 2500
jimcol is offline   Reply With Quote
Old 11-08-2018, 02:31 PM   #4
wprantera
New Member
 
Join Date: May 2017
Location: Bruce Twp.
Posts: 9
M.O.C. #19790
How do you post pictures?
wprantera is offline   Reply With Quote
Old 11-08-2018, 02:41 PM   #5
wprantera
New Member
 
Join Date: May 2017
Location: Bruce Twp.
Posts: 9
M.O.C. #19790
http://www.montanaowners.com/forums/...hp?albumid=161
wprantera is offline   Reply With Quote
Old 11-09-2018, 05:31 AM   #6
wprantera
New Member
 
Join Date: May 2017
Location: Bruce Twp.
Posts: 9
M.O.C. #19790
I think I did it with a little help. Thank you
Attached Images
File Type: jpg Resized_20181014_114528_325.jpg (256.6 KB, 6 views)
File Type: jpg Resized_20181014_114535_6772.jpg (229.9 KB, 6 views)
wprantera is offline   Reply With Quote
Old 11-09-2018, 05:31 AM   #7
wprantera
New Member
 
Join Date: May 2017
Location: Bruce Twp.
Posts: 9
M.O.C. #19790
Does anyone have any ideas on how to fix or what's wrong?
wprantera is offline   Reply With Quote
Old 11-09-2018, 12:43 PM   #8
CarWin
Montana Fan
 
Join Date: Jan 2018
Location: Thornville
Posts: 319
M.O.C. #21110
I`m NOT an ac/heatpump mechanic, but anytime Ive had frozen coils like this its either been low freon or excessively dirty coils causing it.

Others may have a better idea.
__________________
Darwin & Carla
2018.5 3701LK Montana
2016 2500HD Duramax
CarWin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 08:23 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.