Go Back   Montana Owners Club - Keystone Montana 5th Wheel Forum > MOC on M.A.R.S. > Repairs & Service
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 11-28-2012, 02:17 AM   #1
Bigboomer
Montana Master
 
Join Date: Mar 2012
Location: Livingston
Posts: 1,133
M.O.C. #12333
Pump on Splendide Bad!

Nothing like getting a call at work from my DW that "somethings wrong with the washer, it won't drain and the clothes are soaking wet!".

So I first thought that maybe there was something in the drain trap before the pump clogging the water from getting to the pump. I told Sue to look at the manual to locate the pump which she did and removed the front cover and then started to open the pump trap and water started coming out. It took her about 10 minutes or so of carefully removing all the water into a small flat pan. Once drained she unscrewed the trap all the way and she said a little green thing just fell out. Now I get this "Uh Oh" feeling in my gut. This washer/ dryer is 3 months old, what could this be? Asked her to take a pic and send it to me. It looked like a mini turbo prop and I figured it was probably the impeller off the pump. When I got home in the evening I ID'd it as the impeller and it looked like it was a pressed fit on the pump shaft with a metal press fit washer. So I place the impeller back on and tapped it down until it stopped. After re-assembly it worked fine, until.....I get another call the next day...same thing!

Sue called Splendide and explained the issue. The gentlemen on the other end noted it was still under warranty (no kidding) and that we could either take it back to Camping World (2 hours away) and have it repaired (figure it would take 2 weeks) or have a new pump sent to us to replace. In looking at the manual it will take me about an hour max to replace so we chose the latter.

Recieved the pump in 2 days. Will keep you posted with pics of the rehab job....
__________________
Les and Sue Young, 2009 Int 4400 LP, 2015 3610RL, www.ramblingrvrat.blogspot.com, http://s962.photobucket.com/user/myb...Solar%20System
Bigboomer is offline   Reply With Quote
Old 11-28-2012, 04:10 AM   #2
DQDick
Montana Master
 
DQDick's Avatar
 
Join Date: Jun 2011
Location: Wilsey
Posts: 15,460
M.O.C. #11455
We also had a bad pump right out of the box except our's leaked and screwed up the cheap boards under it. Splendide did come thru as promised and we've used the heck out of it for the last year and a half without problems (knock on replaced wood).
__________________
Dick and Joyce, Wilsey, KS & Lakewood, NM
2017 3720 RL, MorRyde pin box
2017 3500 Dodge Maxi Cab DRW 4X4, Pullrite Hitch
IS and Disk Brakes, 3rd AC, Bathroom door mod, etc.
DQDick is offline   Reply With Quote
Old 11-28-2012, 04:42 AM   #3
richfaa
Montana Master
 
Join Date: Jan 2005
Location: North Ridgeville
Posts: 19,206
M.O.C. #2839
Ours is over 6 years old is used hard and not a single problem....knock..knock..
richfaa is offline   Reply With Quote
Old 11-28-2012, 06:07 PM   #4
thekennys
Montana Fan
 
Join Date: Jun 2011
Location: Santa Fe
Posts: 270
M.O.C. #11454
don't forget to ask splendede to hold your hand in the replacement process

mikey
thekennys is offline   Reply With Quote
Old 12-04-2012, 07:59 AM   #5
Bigboomer
Montana Master
 
Join Date: Mar 2012
Location: Livingston
Posts: 1,133
M.O.C. #12333
Well folks wish I can say that the fix for the pump on the Splendide was grossly complicated and that I had to perform major surgery and went back to tech school to learn how to remove the thing. NOT. Basically 6 screws and 2 spring clamps later the old pump was removed and the new pump installed in about 20 minutes. I spent more time cleaning up then I did actually fixing the washer.

No complaints, believe me as I have been on the other end as well.

Here is a link to some pics of the process.

http://s962.beta.photobucket.com/use...20Washer%20Fix

Les
__________________
Les and Sue Young, 2009 Int 4400 LP, 2015 3610RL, www.ramblingrvrat.blogspot.com, http://s962.photobucket.com/user/myb...Solar%20System
Bigboomer is offline   Reply With Quote
Old 12-04-2012, 11:45 AM   #6
8.1al
Montana Master
 
Join Date: Jun 2004
Location: Benson
Posts: 3,099
M.O.C. #1658
Glad hear you got it fixed and it was so easy
8.1al is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Splendide K0LCB Maintenance 4 12-27-2013 06:56 AM
Splendide Drain Away Pan??? cdaniels Additions & Improvements 3 08-08-2011 05:06 PM
Splendide ileyld Additions & Improvements 11 09-01-2009 03:00 PM
Splendide Stackable ..... Delaine and Lindy Montana Problems, Problem Solving & Technical Help 3 02-20-2007 03:40 PM
Splendide Cat320 Montana Problems, Problem Solving & Technical Help 19 11-29-2006 11:51 AM

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Montana RV, Keystone RV Company or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 07:16 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.