Montana Owners Club - Keystone Montana 5th Wheel Forum

Montana Owners Club - Keystone Montana 5th Wheel Forum (http://www.montanaowners.com/forums/index.php)
-   General Discussions about our Montanas (http://www.montanaowners.com/forums/forumdisplay.php?f=4)
-   -   Lippert Level Up Seals Bleeding Back (http://www.montanaowners.com/forums/showthread.php?t=73900)

Retire 2022 05-06-2018 03:28 PM

Lippert Level Up Seals Bleeding Back
 
Auto Level Works Great. I check about once a week to see if it stays "green". Sometimes it shows a red light for the right side which means it is no longer level. Are any of you having this same issue? When I see the red light I just Auto Level it all over again. Could the problem be that the right side Jack seals are bleeding back the fluid over time? Looking forward to hearing a fix for this issue. Thank you, in advance, for replying with a solution.

DadsHemi 05-06-2018 04:25 PM

Mine does the samething, what I’ve noticed sense I’ve owned it a year now and have gone through a season it does it more in the summer time, I check it every couple of weeks, durning fall to spring it does not do it. I’m thinking it’s an expansion/contraction of the fluids.

DQDick 05-06-2018 06:35 PM

Depending on what kind of surface you are parked on it could be the earth settling.

Rondo 05-06-2018 08:46 PM

If you think you have seal leak on the struts-- contact Lippert or LCI Customer Service and let them know what is happening and they will walk you though diagnosing the problem over the phone and/or tell you what is wrong and how to fix it. They are a great bunch to work with!

Retire 2022 05-06-2018 08:57 PM

Thank you for the quick replies. We're parked on asphalt. I will contact Lippert and see what they say. I will post again once I have talked to them to let everyone know what I find out.


All times are GMT -6. The time now is 09:13 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.